CVE-2018-19280 Centreon XSS Vulnerability
Attackers can inject malicious scripts via poller macro names or expressions in Centreon, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-19280?
CVE-2018-19280 is a medium-severity cross-site scripting vulnerability in Centreon Centreon, published on 14 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Centreon 3.4.x (fixed in Centreon 18.10.0) has XSS via the resource name or macro expression of a poller macro.
Weakness: CWE-79
Which versions are affected by CVE-2018-19280?
2 open source packages ship an affected version, including centreon/centreon. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
centreon/centreon Packagist | From 3.4.0 | 18.10.0 |
centreon/centreon Packagist | From 3.4.0 | 18.10.0 |
Products include Centreon Centreon.
How do I fix CVE-2018-19280?
Upgrade centreon/centreon to 18.10.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-19280 being exploited?
There is no known exploitation of CVE-2018-19280 in the wild and no public exploit code.
Other vulnerabilities in Centreon Centreon
Sources
Also known as GHSA-7g3c-hrc6-5v4j.