{"answers":{"affected":"2 open source packages ship an affected version, including valine. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-19289 in the wild and no public exploit code.","fix":"Upgrade valine to 1.3.4 or later.","what":"CVE-2018-19289 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-19289 and fix it if it is affected.\n\nWhat it is: CVE-2018-19289 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-19289 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- valine (npm): affected all versions; fixed in 1.3.4\n- valine (npm): affected all versions; fixed in 1.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-19289/ (Markdown: https://insights.sbomify.com/CVE-2018-19289/index.md)","id":"CVE-2018-19289","markdown":"https://insights.sbomify.com/CVE-2018-19289/index.md","name":"CVE-2018-19289","record":{"aliases":["GHSA-hhrp-qm88-xjr3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Valine comment library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via HTML injection in Valine comments, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"valine","vendor":"valine.js"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in Valine v1.3.3. It allows HTML injection, which can be exploited for JavaScript execution via an EMBED element in conjunction with a .pdf file.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Valine HTML Injection","id":"CVE-2018-19289","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Command injection in n/a","id":"CVE-2018-19290"},"packages":[{"ecosystem":"npm","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"valine","purl":null,"source":"GHSA-hhrp-qm88-xjr3"},{"ecosystem":"npm","fixed":["1.3.4"],"introduced":["0"],"last_affected":[],"package":"valine","purl":"pkg:npm/valine","source":"GHSA-hhrp-qm88-xjr3"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-19288"},"products":["n/a"],"published":"2018-11-15","related":[{"cvss_score":9.6,"headline":"Valine code injection vulnerability","id":"CVE-2022-38545","kev_date_added":null,"published":"2022-09-19"},{"cvss_score":5.4,"headline":"Cross site scripting in valine","id":"CVE-2020-28847","kev_date_added":null,"published":"2022-04-05"},{"cvss_score":5.3,"headline":"Denial of service in Valine","id":"CVE-2021-34801","kev_date_added":null,"published":"2021-06-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary JavaScript via HTML injection in Valine comments, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2018-19289/"}