# CVE-2018-19289: Valine HTML Injection

> Attackers can execute arbitrary JavaScript via HTML injection in Valine comments, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Nov 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hhrp-qm88-xjr3

## What is CVE-2018-19289?

CVE-2018-19289 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Valine v1.3.3. It allows HTML injection, which can be exploited for JavaScript execution via an EMBED element in conjunction with a .pdf file.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-19289?

2 open source packages ship an affected version, including valine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `valine` | npm | All versions | 1.3.4 |
| `valine` | npm | All versions | 1.3.4 |

Products: Valine.js Valine.

## How do I fix CVE-2018-19289?

Upgrade valine to 1.3.4 or later.

## Is CVE-2018-19289 being exploited?

There is no known exploitation of CVE-2018-19289 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-38545](https://insights.sbomify.com/CVE-2022-38545/): Valine code injection vulnerability (critical 9.6)
- [CVE-2020-28847](https://insights.sbomify.com/CVE-2020-28847/): Cross site scripting in valine (medium 5.4)
- [CVE-2021-34801](https://insights.sbomify.com/CVE-2021-34801/): Denial of service in Valine (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19289 and fix it if it is affected.

What it is: CVE-2018-19289 is a medium-severity cross-site scripting vulnerability in n/a, published on 15 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-19289 in the wild and no public exploit code.

Affected packages and fixed versions:
- valine (npm): affected all versions; fixed in 1.3.4
- valine (npm): affected all versions; fixed in 1.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19289/ (Markdown: https://insights.sbomify.com/CVE-2018-19289/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19289
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19289
- OSV: https://osv.dev/vulnerability/CVE-2018-19289

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19289/
Summaries are generated and may contain mistakes; the official description above is the record.
