# CVE-2018-19295: Sylabs Singularity Improper Input Validation

> Local attackers can exploit improper input validation in Singularity to potentially escalate privileges or compromise the container environment.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-p83v-8vmr-qfv9, UBUNTU-CVE-2018-19295, openSUSE-SU-2019:0009-1

## What is CVE-2018-19295?

CVE-2018-19295 is a high-severity vulnerability in n/a, published on 17 Dec 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Sylabs Singularity 2.4 to 2.6 allows local users to conduct Improper Input Validation attacks.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-19295?

2 open source packages ship an affected version, including github.com/sylabs/singularity. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/sylabs/singularity` | Go | From 2.4.0 | 2.6.1 |
| `github.com/sylabs/singularity` | Go | From 2.4.0 | 2.6.1 |
| `singularity` | SUSE:Package Hub 15 | All versions | 2.6.1-bp150.3.6.1 |
| `singularity` | openSUSE:Leap 15.0 | All versions | 2.6.1-bp150.3.6.1 |

Products: Sylabs Singularity.

## How do I fix CVE-2018-19295?

Upgrade github.com/sylabs/singularity to 2.6.1 or later.

## Is CVE-2018-19295 being exploited?

There is no known exploitation of CVE-2018-19295 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-33027](https://insights.sbomify.com/CVE-2021-33027/): Weak cryptography in n/a (critical 9.8)
- [CVE-2021-33622](https://insights.sbomify.com/CVE-2021-33622/): Other in n/a (critical 9.8)
- [CVE-2020-13845](https://insights.sbomify.com/CVE-2020-13845/): Execution Control List (ECL) Is Insecure in Singularity (high 7.5)
- [CVE-2020-13846](https://insights.sbomify.com/CVE-2020-13846/): "Verify All" Returns Success Despite Validation Failures in Singularity (high 7.5)
- [CVE-2020-13847](https://insights.sbomify.com/CVE-2020-13847/): Other in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19295 and fix it if it is affected.

What it is: CVE-2018-19295 is a high-severity vulnerability in n/a, published on 17 Dec 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-19295 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/sylabs/singularity (Go): affected from 2.4.0; fixed in 2.6.1
- github.com/sylabs/singularity (Go): affected from 2.4.0; fixed in 2.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19295/ (Markdown: https://insights.sbomify.com/CVE-2018-19295/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19295
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19295
- OSV: https://osv.dev/vulnerability/CVE-2018-19295

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19295/
Summaries are generated and may contain mistakes; the official description above is the record.
