CVE-2018-19296 Phar object injection in PHPMailer
An attacker can execute arbitrary code via object injection in the PHPMailer library, requiring an upgrade to a patched version.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-19296?
CVE-2018-19296 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 16 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.
Which versions are affected by CVE-2018-19296?
4 open source packages ship an affected version, including phpmailer/phpmailer. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
phpmailer/phpmailer Packagist | From 5.0.0 | 5.2.27 |
phpmailer/phpmailer Packagist | From 5.0.0 | 5.2.27 |
phpmailer/phpmailer Packagist | From 6.0.0 | 6.0.6 |
phpmailer/phpmailer Packagist | From 6.0.0 | 6.0.6 |
Products include Debian Debian Linux, Fedoraproject Fedora, Phpmailer Project Phpmailer, Wordpress Wordpress.
How do I fix CVE-2018-19296?
Upgrade phpmailer/phpmailer to a fixed version for your release line: 5.2.27 or 6.0.6.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2018-19296 being exploited?
There is no known exploitation of CVE-2018-19296 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-19296, DSA-4351-1, GHSA-7w4p-72j7-v7c2, MGASA-2019-0010, UBUNTU-CVE-2018-19296.