{"answers":{"affected":"4 open source packages ship an affected version, including phpmailer/phpmailer. It affects 4 products.","exploited":"There is no known exploitation of CVE-2018-19296 in the wild and no public exploit code.","fix":"Upgrade phpmailer/phpmailer to a fixed version for your release line: 5.2.27 or 6.0.6.","what":"CVE-2018-19296 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 16 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-19296 and fix it if it is affected.\n\nWhat it is: CVE-2018-19296 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 16 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-19296 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.27\n- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.27\n- phpmailer/phpmailer (Packagist): affected from 6.0.0; fixed in 6.0.6\n- phpmailer/phpmailer (Packagist): affected from 6.0.0; fixed in 6.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-19296/ (Markdown: https://insights.sbomify.com/CVE-2018-19296/index.md)","id":"CVE-2018-19296","markdown":"https://insights.sbomify.com/CVE-2018-19296/index.md","name":"CVE-2018-19296","record":{"aliases":["DEBIAN-CVE-2018-19296","DSA-4351-1","GHSA-7w4p-72j7-v7c2","MGASA-2019-0010","UBUNTU-CVE-2018-19296"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP email library","requires_auth":"none","summary":"An attacker can execute arbitrary code via object injection in the PHPMailer library, requiring an upgrade to a patched version.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"phpmailer","vendor":"phpmailer_project"},{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-1321","name":"Improperly Controlled Modification of Object Prototype Attributes"}],"description":"PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Phar object injection in PHPMailer","id":"CVE-2018-19296","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora","wordpress:wordpress"],"type":"deserialization","year":"2018"},"n_packages":4,"n_references":6,"next":{"headline":"Command injection in n/a","id":"CVE-2018-19300"},"packages":[{"ecosystem":"Packagist","fixed":["5.2.27"],"introduced":["5.0.0"],"last_affected":[],"package":"phpmailer/phpmailer","purl":null,"source":"GHSA-7w4p-72j7-v7c2"},{"ecosystem":"Packagist","fixed":["5.2.27"],"introduced":["5.0.0"],"last_affected":[],"package":"phpmailer/phpmailer","purl":"pkg:composer/phpmailer/phpmailer","source":"GHSA-7w4p-72j7-v7c2"},{"ecosystem":"Packagist","fixed":["6.0.6"],"introduced":["6.0.0"],"last_affected":[],"package":"phpmailer/phpmailer","purl":null,"source":"GHSA-7w4p-72j7-v7c2"},{"ecosystem":"Packagist","fixed":["6.0.6"],"introduced":["6.0.0"],"last_affected":[],"package":"phpmailer/phpmailer","purl":"pkg:composer/phpmailer/phpmailer","source":"GHSA-7w4p-72j7-v7c2"}],"prev":{"headline":"Sylabs Singularity Improper Input Validation","id":"CVE-2018-19295"},"products":["n/a"],"published":"2018-11-16","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can execute arbitrary code via object injection in the PHPMailer library, requiring an upgrade to a patched version.","url":"https://insights.sbomify.com/CVE-2018-19296/"}