# CVE-2018-19296: Phar object injection in PHPMailer

> An attacker can execute arbitrary code via object injection in the PHPMailer library, requiring an upgrade to a patched version.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Nov 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-19296, DSA-4351-1, GHSA-7w4p-72j7-v7c2, MGASA-2019-0010, UBUNTU-CVE-2018-19296

## What is CVE-2018-19296?

CVE-2018-19296 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 16 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PHPMailer before 5.2.27 and 6.x before 6.0.6 is vulnerable to an object injection attack.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2018-19296?

4 open source packages ship an affected version, including phpmailer/phpmailer. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.27 |
| `phpmailer/phpmailer` | Packagist | From 5.0.0 | 5.2.27 |
| `phpmailer/phpmailer` | Packagist | From 6.0.0 | 6.0.6 |
| `phpmailer/phpmailer` | Packagist | From 6.0.0 | 6.0.6 |

Products: Debian Debian Linux, Fedoraproject Fedora, Phpmailer Project Phpmailer, Wordpress Wordpress.

## How do I fix CVE-2018-19296?

Upgrade phpmailer/phpmailer to a fixed version for your release line: 5.2.27 or 6.0.6.

## Is CVE-2018-19296 being exploited?

There is no known exploitation of CVE-2018-19296 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19296 and fix it if it is affected.

What it is: CVE-2018-19296 is a high-severity unsafe deserialization vulnerability in Debian Debian Linux, published on 16 Nov 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-19296 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.27
- phpmailer/phpmailer (Packagist): affected from 5.0.0; fixed in 5.2.27
- phpmailer/phpmailer (Packagist): affected from 6.0.0; fixed in 6.0.6
- phpmailer/phpmailer (Packagist): affected from 6.0.0; fixed in 6.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19296/ (Markdown: https://insights.sbomify.com/CVE-2018-19296/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19296
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19296
- OSV: https://osv.dev/vulnerability/CVE-2018-19296

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19296/
Summaries are generated and may contain mistakes; the official description above is the record.
