CVE-2018-19311 Centreon XSS Vulnerability
An attacker can inject malicious scripts via the Service field in Centreon, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-19311?
CVE-2018-19311 is a medium-severity cross-site scripting vulnerability in Centreon Centreon, published on 16 Nov 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Centreon 3.4.x (fixed in Centreon 18.10.0) allows XSS via the Service field to the main.php?p=20201 URI, as demonstrated by the "Monitoring > Status Details > Services" screen.
Weakness: CWE-79
Which versions are affected by CVE-2018-19311?
2 open source packages ship an affected version, including centreon/centreon. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
centreon/centreon Packagist | From 18.0.0 | 18.10.0 |
centreon/centreon Packagist | From 18.0.0 | 18.10.0 |
Products include Centreon Centreon.
How do I fix CVE-2018-19311?
Upgrade centreon/centreon to 18.10.0 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-19311 being exploited?
There is no known exploitation of CVE-2018-19311 in the wild and no public exploit code.
Other vulnerabilities in Centreon Centreon
Sources
Also known as GHSA-8vh5-j6xj-5953.