CVE-2018-19361 Deserialization of Untrusted Data in jackson-databind
Attackers can execute arbitrary code by exploiting unsafe polymorphic deserialization in the jackson-databind library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-19361?
CVE-2018-19361 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 2 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
FasterXML jackson-databind 2.x before 2.9.8 might allow attackers to have unspecified impact by leveraging failure to block the openjpa class from polymorphic deserialization.
Weakness: CWE-502
Which versions are affected by CVE-2018-19361?
6 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 12 products.
| Package | Affected | Fixed in |
|---|---|---|
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.7.9.5 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.7.0 | 2.7.9.5 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.8.0 | 2.8.11.3 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.8.0 | 2.8.11.3 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.8 |
com.fasterxml.jackson.core:jackson-databind Maven | From 2.9.0 | 2.9.8 |
Products include Debian Debian Linux, Fasterxml Jackson-Databind, Oracle Business Process Management Suite, Oracle Primavera P6 Enterprise Project Portfolio Management, Oracle Primavera Unifier, Oracle Retail Workforce Management Software and 6 more.
How do I fix CVE-2018-19361?
Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.7.9.5, 2.8.11.3 or 2.9.8.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2018-19361 being exploited?
There is no known exploitation of CVE-2018-19361 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as CLEANSTART-2026-ZM98203, DEBIAN-CVE-2018-19361, GHSA-mx9v-gmh4-mgqw, UBUNTU-CVE-2018-19361.