# CVE-2018-19362: com.fasterxml.jackson.core:jackson-databind vulnerable to Deserialization of Untrusted Data

> Attackers can achieve remote code execution by exploiting unsafe polymorphic deserialization in the jackson-databind library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2019
- **Updated:** 15 Oct 2026
- **Also known as:** CLEANSTART-2026-GC44596, DEBIAN-CVE-2018-19362, GHSA-c8hm-7hpq-7jhg, ROOT-APP-MAVEN-CVE-2018-19362, UBUNTU-CVE-2018-19362

## What is CVE-2018-19362?

CVE-2018-19362 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 2 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FasterXML jackson-databind 2.x before 2.9.8 might allow attackers to have unspecified impact by leveraging failure to block the jboss-common-core class from polymorphic deserialization.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-19362?

8 open source packages ship an affected version, including com.fasterxml.jackson.core:jackson-databind. It affects 12 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.0.0 | 2.6.7.3 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.0.0 | 2.6.7.3 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.7.0 | 2.7.9.5 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.7.0 | 2.7.9.5 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.8.0 | 2.8.11.3 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.8.0 | 2.8.11.3 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.8 |
| `com.fasterxml.jackson.core:jackson-databind` | Maven | From 2.9.0 | 2.9.8 |

Products: Debian Debian Linux, Fasterxml Jackson-Databind, Oracle Business Process Management Suite, Oracle Primavera P6 Enterprise Project Portfolio Management, Oracle Primavera Unifier, Oracle Retail Workforce Management Software, Oracle Webcenter Portal, Redhat Automation Manager, Redhat Decision Manager, Redhat Jboss Bpm Suite, Redhat Jboss Brms, Redhat Openshift Container Platform.

## How do I fix CVE-2018-19362?

Upgrade com.fasterxml.jackson.core:jackson-databind to a fixed version for your release line: 2.6.7.3, 2.7.9.5, 2.8.11.3 or 2.9.8.

## Is CVE-2018-19362 being exploited?

There is no known exploitation of CVE-2018-19362 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19362 and fix it if it is affected.

What it is: CVE-2018-19362 is a critical unsafe deserialization vulnerability in Debian Debian Linux, published on 2 Jan 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-19362 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.0.0; fixed in 2.6.7.3
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.0.0; fixed in 2.6.7.3
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.7.0; fixed in 2.7.9.5
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.7.0; fixed in 2.7.9.5
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.8.0; fixed in 2.8.11.3
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.8.0; fixed in 2.8.11.3
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.8
- com.fasterxml.jackson.core:jackson-databind (Maven): affected from 2.9.0; fixed in 2.9.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19362/ (Markdown: https://insights.sbomify.com/CVE-2018-19362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19362
- OSV: https://osv.dev/vulnerability/CVE-2018-19362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19362/
Summaries are generated and may contain mistakes; the official description above is the record.
