# CVE-2018-19413: Exposure of Sensitive Information to an Unauthorized Actor in SonarSource SonarQube API

> Authenticated users can access sensitive user-account logins via the API due to improper access controls, aiding further attacks.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m643-2pfv-xwm8

## What is CVE-2018-19413?

CVE-2018-19413 is a medium-severity vulnerability in n/a, published on 14 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability in the API of SonarSource SonarQube before 7.4 could allow an authenticated user to discover sensitive information such as valid user-account logins in the web application. The vulnerability occurs because of improperly configured access controls that cause the API to return the externalIdentity field to non-administrator users. The attacker could use this information in subsequent attacks against the system.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-19413?

2 open source packages ship an affected version, including org.sonarsource.sonarqube:sonar-plugin-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.sonarsource.sonarqube:sonar-plugin-api` | Maven | All versions | 7.5 |
| `org.sonarsource.sonarqube:sonar-plugin-api` | Maven | All versions | 7.5 |

Products: Sonarsource Sonarqube.

## How do I fix CVE-2018-19413?

Upgrade org.sonarsource.sonarqube:sonar-plugin-api to 7.5 or later.

## Is CVE-2018-19413 being exploited?

There is no known exploitation of CVE-2018-19413 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-27986](https://insights.sbomify.com/CVE-2020-27986/): Information disclosure in n/a (high 7.5)
- [CVE-2024-47911](https://insights.sbomify.com/CVE-2024-47911/): SQL injection in n/a (medium 6.7)
- [CVE-2019-17579](https://insights.sbomify.com/CVE-2019-17579/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2020-28002](https://insights.sbomify.com/CVE-2020-28002/): Auth bypass in n/a (medium 5.3)
- [CVE-2024-38460](https://insights.sbomify.com/CVE-2024-38460/): SonarQube logs sensitive information (medium 4.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19413 and fix it if it is affected.

What it is: CVE-2018-19413 is a medium-severity vulnerability in n/a, published on 14 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-19413 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.sonarsource.sonarqube:sonar-plugin-api (Maven): affected all versions; fixed in 7.5
- org.sonarsource.sonarqube:sonar-plugin-api (Maven): affected all versions; fixed in 7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19413/ (Markdown: https://insights.sbomify.com/CVE-2018-19413/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19413
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19413
- OSV: https://osv.dev/vulnerability/CVE-2018-19413

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19413/
Summaries are generated and may contain mistakes; the official description above is the record.
