{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-19456 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2018-19456 is a high-severity vulnerability in Opensuse Leap, published on 7 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-19456 and fix it if it is affected.\n\nWhat it is: CVE-2018-19456 is a high-severity vulnerability in Opensuse Leap, published on 7 May 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-19456 in the wild and no public exploit code.\n\nAffected product: Opensuse Leap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-19456/ (Markdown: https://insights.sbomify.com/CVE-2018-19456/index.md)","id":"CVE-2018-19456","markdown":"https://insights.sbomify.com/CVE-2018-19456/index.md","name":"CVE-2018-19456","record":{"aliases":["GHSA-gfq3-c4vg-p6gr","SUSE-SU-2019:0024-1"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"none","summary":"Remote attackers can obtain sensitive information from server folders and files via the WP Backup+ plugin for WordPress.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"leap","vendor":"opensuse"},{"product":"wpbackupplus","vendor":"wplaunchpad"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The WP Backup+ (aka WPbackupplus) plugin through 2018-11-22 for WordPress allows remote attackers to obtain sensitive information from server folders and files, as demonstrated by download.sql.","ecosystems":["SUSE:Linux Enterprise Software Development Kit 12 SP3","SUSE:Linux Enterprise Software Development Kit 12 SP4","SUSE:Manager Server 3.1","SUSE:Manager Server 3.2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in n/a","id":"CVE-2018-19456","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:leap","products":["opensuse:leap"],"type":"information_disclosure","year":"2018"},"n_packages":4,"n_references":2,"next":{"headline":"File upload in n/a","id":"CVE-2018-19457"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["0.24.1-7.9.1"],"introduced":["0"],"last_affected":[],"package":"libgit2","purl":"pkg:rpm/suse/libgit2\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2019:0024-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP4","fixed":["0.24.1-7.9.1"],"introduced":["0"],"last_affected":[],"package":"libgit2","purl":"pkg:rpm/suse/libgit2\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP4","source":"SUSE-SU-2019:0024-1"},{"ecosystem":"SUSE:Manager Server 3.1","fixed":["0.24.1-7.9.1"],"introduced":["0"],"last_affected":[],"package":"libgit2","purl":"pkg:rpm/suse/libgit2\u0026distro=SUSE%20Manager%20Server%203.1","source":"SUSE-SU-2019:0024-1"},{"ecosystem":"SUSE:Manager Server 3.2","fixed":["0.24.1-7.9.1"],"introduced":["0"],"last_affected":[],"package":"libgit2","purl":"pkg:rpm/suse/libgit2\u0026distro=SUSE%20Manager%20Server%203.2","source":"SUSE-SU-2019:0024-1"}],"prev":{"headline":"File upload in n/a","id":"CVE-2018-19453"},"products":["n/a"],"published":"2019-05-07","related":[{"cvss_score":5.3,"headline":"Oracle Java SE Integrity Check","id":"CVE-2015-4902","kev_date_added":"2022-03-03","published":"2015-10-21"},{"cvss_score":9.9,"headline":"package builds could use directory traversal to write outside of target area","id":"CVE-2017-14804","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":9.8,"headline":"Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size.","id":"CVE-2019-20787","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-8341","kev_date_added":null,"published":"2019-02-15"},{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2019-6438","kev_date_added":null,"published":"2019-01-31"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-18215","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-6542","kev_date_added":null,"published":"2017-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can obtain sensitive information from server folders and files via the WP Backup+ plugin for WordPress.","url":"https://insights.sbomify.com/CVE-2018-19456/"}