{"answers":{"affected":"2 open source packages ship an affected version, including athlon1600/php-proxy-app. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-19785 in the wild and no public exploit code.","fix":"Upgrade athlon1600/php-proxy-app to 3.0 or later.","what":"CVE-2018-19785 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-19785 and fix it if it is affected.\n\nWhat it is: CVE-2018-19785 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-19785 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- athlon1600/php-proxy-app (Packagist): affected all versions; fixed in 3.0\n- athlon1600/php-proxy-app (Packagist): affected all versions; fixed in 3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-19785/ (Markdown: https://insights.sbomify.com/CVE-2018-19785/index.md)","id":"CVE-2018-19785","markdown":"https://insights.sbomify.com/CVE-2018-19785/index.md","name":"CVE-2018-19785","record":{"aliases":["GHSA-cghj-w42g-hqmr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP proxy library","requires_auth":"none","summary":"An attacker can execute arbitrary scripts in the victim's browser via the URL field in this PHP proxy library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"php-proxy","vendor":"php-proxy"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"PHP-Proxy through 5.1.0 has Cross-Site Scripting (XSS) via the URL field in index.php.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS in PHP-Proxy-App through v3.0","id":"CVE-2018-19785","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2018"},"n_packages":2,"n_references":2,"next":{"headline":"Information disclosure in n/a","id":"CVE-2018-19786"},"packages":[{"ecosystem":"Packagist","fixed":["3.0"],"introduced":["0"],"last_affected":[],"package":"athlon1600/php-proxy-app","purl":null,"source":"GHSA-cghj-w42g-hqmr"},{"ecosystem":"Packagist","fixed":["3.0"],"introduced":["0"],"last_affected":[],"package":"athlon1600/php-proxy-app","purl":"pkg:composer/athlon1600/php-proxy-app","source":"GHSA-cghj-w42g-hqmr"}],"prev":{"headline":"Weak Cryptography in PHP-Proxy","id":"CVE-2018-19784"},"products":["n/a"],"published":"2018-12-01","related":[{"cvss_score":7.5,"headline":"Weak Cryptography in PHP-Proxy","id":"CVE-2018-19784","kev_date_added":null,"published":"2018-12-01"},{"cvss_score":7.5,"headline":"Unauthenticated File Read in PHP Proxy","id":"CVE-2018-19458","kev_date_added":null,"published":"2018-11-22"},{"cvss_score":7.5,"headline":"LFI in PHP-Proxy 5.1.0","id":"CVE-2018-19246","kev_date_added":null,"published":"2018-11-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can execute arbitrary scripts in the victim's browser via the URL field in this PHP proxy library.","url":"https://insights.sbomify.com/CVE-2018-19785/"}