CVE-2018-19789 Symfony Path Disclosure
Attackers can disclose uploaded file paths via type hinting flaws, potentially enabling remote code execution if combined with local file inclusion.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-19789?
CVE-2018-19789 is a medium-severity vulnerability in Debian Debian Linux, published on 18 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Symfony 2.7.x before 2.7.50, 2.8.x before 2.8.49, 3.x before 3.4.20, 4.0.x before 4.0.15, 4.1.x before 4.1.9, and 4.2.x before 4.2.1. When using the scalar type hint `string` in a setter method (e.g. `setName(string $name)`) of a class that's the `data_class` of a form, and when a file upload is submitted to the corresponding field instead of a normal text input, then `UploadedFile::__toString()` is called which will then return and disclose the path of the uploaded file. If combined with a local file inclusion issue in certain circumstances this could escalate it to a Remote Code Execution.
Weakness: CWE-434
Which versions are affected by CVE-2018-19789?
24 open source packages ship an affected version, including symfony/form and symfony/symfony. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/form Packagist | From 2.7.0 | 2.7.50 |
symfony/form Packagist | From 2.7.0 | 2.7.50 |
symfony/form Packagist | From 2.8.0 | 2.8.49 |
symfony/form Packagist | From 2.8.0 | 2.8.49 |
symfony/form Packagist | From 3.0.0 | 3.4.20 |
symfony/form Packagist | From 3.0.0 | 3.4.20 |
18 more packages
symfony/form Packagist | From 4.0.0 | 4.0.15 |
symfony/form Packagist | From 4.0.0 | 4.0.15 |
symfony/form Packagist | From 4.1.0 | 4.1.9 |
symfony/form Packagist | From 4.1.0 | 4.1.9 |
symfony/form Packagist | From 4.2.0 | 4.2.1 |
symfony/form Packagist | From 4.2.0 | 4.2.1 |
symfony/symfony Packagist | From 2.7.0 | 2.7.50 |
symfony/symfony Packagist | From 2.7.0 | 2.7.50 |
symfony/symfony Packagist | From 2.8.0 | 2.8.49 |
symfony/symfony Packagist | From 2.8.0 | 2.8.49 |
symfony/symfony Packagist | From 3.0.0 | 3.4.20 |
symfony/symfony Packagist | From 3.0.0 | 3.4.20 |
symfony/symfony Packagist | From 4.0.0 | 4.0.15 |
symfony/symfony Packagist | From 4.0.0 | 4.0.15 |
symfony/symfony Packagist | From 4.1.0 | 4.1.9 |
symfony/symfony Packagist | From 4.1.0 | 4.1.9 |
symfony/symfony Packagist | From 4.2.0 | 4.2.1 |
symfony/symfony Packagist | From 4.2.0 | 4.2.1 |
Products include Debian Debian Linux, Sensiolabs Symfony.
How do I fix CVE-2018-19789?
Upgrade symfony/form to a fixed version for your release line: 2.7.50, 2.8.49, 3.4.20 or 4.0.15.
Is CVE-2018-19789 being exploited?
There is no known exploitation of CVE-2018-19789 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-19789, GHSA-x3cf-w64x-4cp2, UBUNTU-CVE-2018-19789.