# CVE-2018-19789: Symfony Path Disclosure

> Attackers can disclose uploaded file paths via type hinting flaws, potentially enabling remote code execution if combined with local file inclusion.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-19789, GHSA-x3cf-w64x-4cp2, UBUNTU-CVE-2018-19789

## What is CVE-2018-19789?

CVE-2018-19789 is a medium-severity vulnerability in Debian Debian Linux, published on 18 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in Symfony 2.7.x before 2.7.50, 2.8.x before 2.8.49, 3.x before 3.4.20, 4.0.x before 4.0.15, 4.1.x before 4.1.9, and 4.2.x before 4.2.1. When using the scalar type hint `string` in a setter method (e.g. `setName(string $name)`) of a class that's the `data_class` of a form, and when a file upload is submitted to the corresponding field instead of a normal text input, then `UploadedFile::__toString()` is called which will then return and disclose the path of the uploaded file. If combined with a local file inclusion issue in certain circumstances this could escalate it to a Remote Code Execution.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2018-19789?

24 open source packages ship an affected version, including symfony/form and symfony/symfony. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/form` | Packagist | From 2.7.0 | 2.7.50 |
| `symfony/form` | Packagist | From 2.7.0 | 2.7.50 |
| `symfony/form` | Packagist | From 2.8.0 | 2.8.49 |
| `symfony/form` | Packagist | From 2.8.0 | 2.8.49 |
| `symfony/form` | Packagist | From 3.0.0 | 3.4.20 |
| `symfony/form` | Packagist | From 3.0.0 | 3.4.20 |
| `symfony/form` | Packagist | From 4.0.0 | 4.0.15 |
| `symfony/form` | Packagist | From 4.0.0 | 4.0.15 |
| `symfony/form` | Packagist | From 4.1.0 | 4.1.9 |
| `symfony/form` | Packagist | From 4.1.0 | 4.1.9 |
| `symfony/form` | Packagist | From 4.2.0 | 4.2.1 |
| `symfony/form` | Packagist | From 4.2.0 | 4.2.1 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.50 |
| `symfony/symfony` | Packagist | From 2.7.0 | 2.7.50 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.49 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.49 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.20 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.20 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.0.15 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.0.15 |
| `symfony/symfony` | Packagist | From 4.1.0 | 4.1.9 |
| `symfony/symfony` | Packagist | From 4.1.0 | 4.1.9 |
| `symfony/symfony` | Packagist | From 4.2.0 | 4.2.1 |
| `symfony/symfony` | Packagist | From 4.2.0 | 4.2.1 |

Products: Debian Debian Linux, Sensiolabs Symfony.

## How do I fix CVE-2018-19789?

Upgrade symfony/form to a fixed version for your release line: 2.7.50, 2.8.49, 3.4.20 or 4.0.15.

## Is CVE-2018-19789 being exploited?

There is no known exploitation of CVE-2018-19789 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19789 and fix it if it is affected.

What it is: CVE-2018-19789 is a medium-severity vulnerability in Debian Debian Linux, published on 18 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-19789 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/form (Packagist): affected from 2.7.0; fixed in 2.7.50
- symfony/form (Packagist): affected from 2.7.0; fixed in 2.7.50
- symfony/form (Packagist): affected from 2.8.0; fixed in 2.8.49
- symfony/form (Packagist): affected from 2.8.0; fixed in 2.8.49
- symfony/form (Packagist): affected from 3.0.0; fixed in 3.4.20
- symfony/form (Packagist): affected from 3.0.0; fixed in 3.4.20
- symfony/form (Packagist): affected from 4.0.0; fixed in 4.0.15
- symfony/form (Packagist): affected from 4.0.0; fixed in 4.0.15
- symfony/form (Packagist): affected from 4.1.0; fixed in 4.1.9
- symfony/form (Packagist): affected from 4.1.0; fixed in 4.1.9
- symfony/form (Packagist): affected from 4.2.0; fixed in 4.2.1
- symfony/form (Packagist): affected from 4.2.0; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19789/ (Markdown: https://insights.sbomify.com/CVE-2018-19789/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19789
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19789
- OSV: https://osv.dev/vulnerability/CVE-2018-19789

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19789/
Summaries are generated and may contain mistakes; the official description above is the record.
