CVE-2018-19790 Symfony Open Redirect
Attackers can bypass redirection restrictions in Symfony login forms using backslashes, redirecting users to arbitrary external domains after authentication.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-19790?
CVE-2018-19790 is a medium-severity vulnerability in Debian Debian Linux, published on 18 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
An open redirect was discovered in Symfony 2.7.x before 2.7.50, 2.8.x before 2.8.49, 3.x before 3.4.20, 4.0.x before 4.0.15, 4.1.x before 4.1.9 and 4.2.x before 4.2.1. By using backslashes in the `_failure_path` input field of login forms, an attacker can work around the redirection target restrictions and effectively redirect the user to any domain after login.
Weakness: CWE-601
Which versions are affected by CVE-2018-19790?
34 open source packages ship an affected version, including symfony/security, symfony/security-http and symfony/symfony. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
symfony/security Packagist | From 2.7.38 | 2.7.50 |
symfony/security Packagist | From 2.7.38 | 2.7.50 |
symfony/security Packagist | From 2.8.0 | 2.8.49 |
symfony/security Packagist | From 2.8.0 | 2.8.49 |
symfony/security Packagist | From 3.0.0 | 3.4.19 |
symfony/security Packagist | From 3.0.0 | 3.4.19 |
28 more packages
symfony/security Packagist | From 4.0.0 | 4.0.15 |
symfony/security Packagist | From 4.0.0 | 4.0.15 |
symfony/security Packagist | From 4.1.0 | 4.1.9 |
symfony/security Packagist | From 4.1.0 | 4.1.9 |
symfony/security Packagist | From 4.2.0 | 4.2.1 |
symfony/security Packagist | From 4.2.0 | 4.2.1 |
symfony/security-http Packagist | From 2.7.38 | 2.7.50 |
symfony/security-http Packagist | From 2.7.38 | 2.7.50 |
symfony/security-http Packagist | From 2.8.0 | 2.8.49 |
symfony/security-http Packagist | From 2.8.0 | 2.8.49 |
symfony/security-http Packagist | From 3.0.0 | 3.4.20 |
symfony/security-http Packagist | From 3.0.0 | 3.4.20 |
symfony/security-http Packagist | From 4.0.0 | 4.0.15 |
symfony/security-http Packagist | From 4.0.0 | 4.0.15 |
symfony/security-http Packagist | From 4.1.0 | 4.1.9 |
symfony/security-http Packagist | From 4.1.0 | 4.1.9 |
symfony/security-http Packagist | From 4.2.0 | 4.2.1 |
symfony/security-http Packagist | From 4.2.0 | 4.2.1 |
symfony/symfony Packagist | From 2.7.38 | 2.7.50 |
symfony/symfony Packagist | From 2.7.38 | 2.7.50 |
symfony/symfony Packagist | From 2.8.0 | 2.8.49 |
symfony/symfony Packagist | From 2.8.0 | 2.8.49 |
symfony/symfony Packagist | From 3.0.0 | 3.4.20 |
symfony/symfony Packagist | From 3.0.0 | 3.4.20 |
symfony/symfony Packagist | From 4.0.0 | 4.0.15 |
symfony/symfony Packagist | From 4.0.0 | 4.0.15 |
symfony/symfony Packagist | From 4.1.0 | 4.1.9 |
symfony/symfony Packagist | From 4.1.0 | 4.1.9 |
Products include Debian Debian Linux, Fedoraproject Fedora, Sensiolabs Symfony.
How do I fix CVE-2018-19790?
Upgrade symfony/security to a fixed version for your release line: 2.7.50, 2.8.49, 3.4.19 or 4.0.15.
Is CVE-2018-19790 being exploited?
There is no known exploitation of CVE-2018-19790 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-19790, GHSA-89r2-5g34-2g47, UBUNTU-CVE-2018-19790.