# CVE-2018-19790: Symfony Open Redirect

> Attackers can bypass redirection restrictions in Symfony login forms using backslashes, redirecting users to arbitrary external domains after authentication.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-19790, GHSA-89r2-5g34-2g47, UBUNTU-CVE-2018-19790

## What is CVE-2018-19790?

CVE-2018-19790 is a medium-severity vulnerability in Debian Debian Linux, published on 18 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An open redirect was discovered in Symfony 2.7.x before 2.7.50, 2.8.x before 2.8.49, 3.x before 3.4.20, 4.0.x before 4.0.15, 4.1.x before 4.1.9 and 4.2.x before 4.2.1. By using backslashes in the `_failure_path` input field of login forms, an attacker can work around the redirection target restrictions and effectively redirect the user to any domain after login.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2018-19790?

34 open source packages ship an affected version, including symfony/security, symfony/security-http and symfony/symfony. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security` | Packagist | From 2.7.38 | 2.7.50 |
| `symfony/security` | Packagist | From 2.7.38 | 2.7.50 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.49 |
| `symfony/security` | Packagist | From 2.8.0 | 2.8.49 |
| `symfony/security` | Packagist | From 3.0.0 | 3.4.19 |
| `symfony/security` | Packagist | From 3.0.0 | 3.4.19 |
| `symfony/security` | Packagist | From 4.0.0 | 4.0.15 |
| `symfony/security` | Packagist | From 4.0.0 | 4.0.15 |
| `symfony/security` | Packagist | From 4.1.0 | 4.1.9 |
| `symfony/security` | Packagist | From 4.1.0 | 4.1.9 |
| `symfony/security` | Packagist | From 4.2.0 | 4.2.1 |
| `symfony/security` | Packagist | From 4.2.0 | 4.2.1 |
| `symfony/security-http` | Packagist | From 2.7.38 | 2.7.50 |
| `symfony/security-http` | Packagist | From 2.7.38 | 2.7.50 |
| `symfony/security-http` | Packagist | From 2.8.0 | 2.8.49 |
| `symfony/security-http` | Packagist | From 2.8.0 | 2.8.49 |
| `symfony/security-http` | Packagist | From 3.0.0 | 3.4.20 |
| `symfony/security-http` | Packagist | From 3.0.0 | 3.4.20 |
| `symfony/security-http` | Packagist | From 4.0.0 | 4.0.15 |
| `symfony/security-http` | Packagist | From 4.0.0 | 4.0.15 |
| `symfony/security-http` | Packagist | From 4.1.0 | 4.1.9 |
| `symfony/security-http` | Packagist | From 4.1.0 | 4.1.9 |
| `symfony/security-http` | Packagist | From 4.2.0 | 4.2.1 |
| `symfony/security-http` | Packagist | From 4.2.0 | 4.2.1 |
| `symfony/symfony` | Packagist | From 2.7.38 | 2.7.50 |
| `symfony/symfony` | Packagist | From 2.7.38 | 2.7.50 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.49 |
| `symfony/symfony` | Packagist | From 2.8.0 | 2.8.49 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.20 |
| `symfony/symfony` | Packagist | From 3.0.0 | 3.4.20 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.0.15 |
| `symfony/symfony` | Packagist | From 4.0.0 | 4.0.15 |
| `symfony/symfony` | Packagist | From 4.1.0 | 4.1.9 |
| `symfony/symfony` | Packagist | From 4.1.0 | 4.1.9 |

Products: Debian Debian Linux, Fedoraproject Fedora, Sensiolabs Symfony.

## How do I fix CVE-2018-19790?

Upgrade symfony/security to a fixed version for your release line: 2.7.50, 2.8.49, 3.4.19 or 4.0.15.

## Is CVE-2018-19790 being exploited?

There is no known exploitation of CVE-2018-19790 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19790 and fix it if it is affected.

What it is: CVE-2018-19790 is a medium-severity vulnerability in Debian Debian Linux, published on 18 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-19790 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security (Packagist): affected from 2.7.38; fixed in 2.7.50
- symfony/security (Packagist): affected from 2.7.38; fixed in 2.7.50
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.49
- symfony/security (Packagist): affected from 2.8.0; fixed in 2.8.49
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.4.19
- symfony/security (Packagist): affected from 3.0.0; fixed in 3.4.19
- symfony/security (Packagist): affected from 4.0.0; fixed in 4.0.15
- symfony/security (Packagist): affected from 4.0.0; fixed in 4.0.15
- symfony/security (Packagist): affected from 4.1.0; fixed in 4.1.9
- symfony/security (Packagist): affected from 4.1.0; fixed in 4.1.9
- symfony/security (Packagist): affected from 4.2.0; fixed in 4.2.1
- symfony/security (Packagist): affected from 4.2.0; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19790/ (Markdown: https://insights.sbomify.com/CVE-2018-19790/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19790
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19790
- OSV: https://osv.dev/vulnerability/CVE-2018-19790

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19790/
Summaries are generated and may contain mistakes; the official description above is the record.
