{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-19865 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-19865 is a high-severity vulnerability in Opensuse Leap, published on 5 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-19865 and fix it if it is affected.\n\nWhat it is: CVE-2018-19865 is a high-severity vulnerability in Opensuse Leap, published on 5 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-19865 in the wild and no public exploit code.\n\nAffected product: Opensuse Leap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-19865/ (Markdown: https://insights.sbomify.com/CVE-2018-19865/index.md)","id":"CVE-2018-19865","markdown":"https://insights.sbomify.com/CVE-2018-19865/index.md","name":"CVE-2018-19865","record":{"aliases":["DEBIAN-CVE-2018-19865","GHSA-f68g-4p63-5wh7","UBUNTU-CVE-2018-19865","openSUSE-SU-2019:1259-1","openSUSE-SU-2019:1263-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Qt Virtual Keyboard","requires_auth":"none","summary":"An attacker can log keystrokes via the Qt Virtual Keyboard component, potentially exposing sensitive user input.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"leap","vendor":"opensuse"},{"product":"qt","vendor":"qt"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"}],"description":"A keystroke logging issue was discovered in Virtual Keyboard in Qt 5.7.x, 5.8.x, 5.9.x, 5.10.x, and 5.11.x before 5.11.3.","ecosystems":["SUSE:Package Hub 15","openSUSE:Leap 15.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Information disclosure in n/a","id":"CVE-2018-19865","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:leap","products":["opensuse:leap","qt:qt"],"type":"information_disclosure","year":"2018"},"n_packages":2,"n_references":13,"next":{"headline":"Denial of service in n/a","id":"CVE-2018-19869"},"packages":[{"ecosystem":"SUSE:Package Hub 15","fixed":["5.9.4-bp150.3.3.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtvirtualkeyboard","purl":"pkg:rpm/suse/libqt5-qtvirtualkeyboard\u0026distro=SUSE%20Package%20Hub%2015","source":"openSUSE-SU-2019:1263-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["5.9.4-lp150.2.3.1"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtvirtualkeyboard","purl":"pkg:rpm/opensuse/libqt5-qtvirtualkeyboard\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:1259-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2018-19864"},"products":["n/a"],"published":"2018-12-05","related":[{"cvss_score":5.3,"headline":"Oracle Java SE Integrity Check","id":"CVE-2015-4902","kev_date_added":"2022-03-03","published":"2015-10-21"},{"cvss_score":9.9,"headline":"package builds could use directory traversal to write outside of target area","id":"CVE-2017-14804","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":9.8,"headline":"Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size.","id":"CVE-2019-20787","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-8341","kev_date_added":null,"published":"2019-02-15"},{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2019-6438","kev_date_added":null,"published":"2019-01-31"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-18215","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-6542","kev_date_added":null,"published":"2017-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can log keystrokes via the Qt Virtual Keyboard component, potentially exposing sensitive user input.","url":"https://insights.sbomify.com/CVE-2018-19865/"}