{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2018-19869 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2018-19869 is a medium-severity denial of service vulnerability in Opensuse Leap, published on 26 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-19869 and fix it if it is affected.\n\nWhat it is: CVE-2018-19869 is a medium-severity denial of service vulnerability in Opensuse Leap, published on 26 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-19869 in the wild and no public exploit code.\n\nAffected product: Opensuse Leap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-19869/ (Markdown: https://insights.sbomify.com/CVE-2018-19869/index.md)","id":"CVE-2018-19869","markdown":"https://insights.sbomify.com/CVE-2018-19869/index.md","name":"CVE-2018-19869","record":{"aliases":["DEBIAN-CVE-2018-19869","DLA-2422-1","GHSA-pmgg-wc2m-p4m6","SUSE-SU-2019:0706-1","SUSE-SU-2020:2924-1","UBUNTU-CVE-2018-19869","openSUSE-SU-2019:1116-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Qt SVG library","requires_auth":"none","summary":"A malformed SVG image causes a segmentation fault in the Qt library, leading to a denial of service for applications using it.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"leap","vendor":"opensuse"},{"product":"qt","vendor":"qt"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An issue was discovered in Qt before 5.11.3. A malformed SVG image causes a segmentation fault in qsvghandler.cpp.","ecosystems":["SUSE:Linux Enterprise Module for Basesystem 15","SUSE:Linux Enterprise Module for Desktop Applications 15","SUSE:Linux Enterprise Server 12 SP5","SUSE:Linux Enterprise Server for SAP Applications 12 SP5","SUSE:Linux Enterprise Software Development Kit 12 SP5","openSUSE:Leap 15.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2018-19869","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:leap","products":["opensuse:leap","qt:qt"],"type":"denial_of_service","year":"2018"},"n_packages":6,"n_references":11,"next":{"headline":"Null dereference in n/a","id":"CVE-2018-19870"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15","fixed":["5.9.4-3.3.19"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtsvg","purl":"pkg:rpm/suse/libqt5-qtsvg\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015","source":"SUSE-SU-2019:0706-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Desktop Applications 15","fixed":["5.9.4-3.3.19"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtsvg","purl":"pkg:rpm/suse/libqt5-qtsvg\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Desktop%20Applications%2015","source":"SUSE-SU-2019:0706-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5","fixed":["5.6.2-3.3.110"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtsvg","purl":"pkg:rpm/suse/libqt5-qtsvg\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5","source":"SUSE-SU-2020:2924-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP5","fixed":["5.6.2-3.3.110"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtsvg","purl":"pkg:rpm/suse/libqt5-qtsvg\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP5","source":"SUSE-SU-2020:2924-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["5.6.2-3.3.110"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtsvg","purl":"pkg:rpm/suse/libqt5-qtsvg\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2020:2924-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["5.9.4-lp150.2.3.2"],"introduced":["0"],"last_affected":[],"package":"libqt5-qtsvg","purl":"pkg:rpm/opensuse/libqt5-qtsvg\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:1116-1"}],"prev":{"headline":"Information disclosure in n/a","id":"CVE-2018-19865"},"products":["n/a"],"published":"2018-12-26","related":[{"cvss_score":5.3,"headline":"Oracle Java SE Integrity Check","id":"CVE-2015-4902","kev_date_added":"2022-03-03","published":"2015-10-21"},{"cvss_score":9.9,"headline":"package builds could use directory traversal to write outside of target area","id":"CVE-2017-14804","kev_date_added":null,"published":"2018-03-01"},{"cvss_score":9.8,"headline":"Teeworlds before 0.7.4 has an integer overflow when computing a tilemap size.","id":"CVE-2019-20787","kev_date_added":null,"published":"2020-04-22"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-8341","kev_date_added":null,"published":"2019-02-15"},{"cvss_score":9.8,"headline":"Other in n/a","id":"CVE-2019-6438","kev_date_added":null,"published":"2019-01-31"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-18215","kev_date_added":null,"published":"2018-03-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-6542","kev_date_added":null,"published":"2017-03-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A malformed SVG image causes a segmentation fault in the Qt library, leading to a denial of service for applications using it.","url":"https://insights.sbomify.com/CVE-2018-19869/"}