# CVE-2018-19933: Bolt Cross-site Scripting (XSS) via text input click preview button

> An attacker can execute arbitrary scripts in the context of other users' browsers via the Title field in Bolt CMS.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gjx6-58xh-p7pw

## What is CVE-2018-19933?

CVE-2018-19933 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Bolt CMS <3.6.2 allows XSS via text input click preview button as demonstrated by the Title field of a Configured and New Entry.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-19933?

2 open source packages ship an affected version, including bolt/bolt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bolt/bolt` | Packagist | All versions | 3.6.2 |
| `bolt/bolt` | Packagist | All versions | 3.6.2 |

Products: Bolt Bolt Cms.

## How do I fix CVE-2018-19933?

Upgrade bolt/bolt to 3.6.2 or later.

## Is CVE-2018-19933 being exploited?

There is no known exploitation of CVE-2018-19933 in the wild and no public exploit code.

Public exploit code:

- Bolt CMS < 3.6.2 - Cross-Site Scripting (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2022-36532](https://insights.sbomify.com/CVE-2022-36532/): File upload in n/a (high 8.8)
- [CVE-2021-40219](https://insights.sbomify.com/CVE-2021-40219/): Code Injection in Bolt CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19933 and fix it if it is affected.

What it is: CVE-2018-19933 is a medium-severity cross-site scripting vulnerability in n/a, published on 17 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-19933 in the wild and no public exploit code.

Affected packages and fixed versions:
- bolt/bolt (Packagist): affected all versions; fixed in 3.6.2
- bolt/bolt (Packagist): affected all versions; fixed in 3.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19933/ (Markdown: https://insights.sbomify.com/CVE-2018-19933/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19933
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19933
- OSV: https://osv.dev/vulnerability/CVE-2018-19933

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19933/
Summaries are generated and may contain mistakes; the official description above is the record.
