# CVE-2018-19947: Information disclosure in Helpdesk

> An attacker can exploit this vulnerability to disclose sensitive information from the QNAP Helpdesk application.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 11 Sep 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-h4wq-q9hr-ffm6

## What is CVE-2018-19947?

CVE-2018-19947 is a medium-severity vulnerability in QNAP Systems Inc. Helpdesk, published on 11 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The vulnerability have been reported to affect earlier versions of Helpdesk. If exploited, this information exposure vulnerability could disclose sensitive information. QNAP has already fixed the issue in Helpdesk 3.0.3 and later.

Weakness: CWE-210 (Self-generated Error Message Containing Sensitive Information), CWE-209 (Generation of Error Message Containing Sensitive Information), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-19947?

It affects 1 product.


Products: Qnap Helpdesk.

## How do I fix CVE-2018-19947?

No fix has been published for CVE-2018-19947 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-19947 being exploited?

There is no known exploitation of CVE-2018-19947 in the wild and no public exploit code.

## Other vulnerabilities in QNAP Systems Inc. Helpdesk

- [CVE-2020-2506](https://insights.sbomify.com/CVE-2020-2506/): QNAP Helpdesk Improper Access Control (high 7.3, exploited in the wild)
- [CVE-2020-2507](https://insights.sbomify.com/CVE-2020-2507/): command injection vulnerability in Helpdesk (critical 9.8)
- [CVE-2020-2500](https://insights.sbomify.com/CVE-2020-2500/): Hardcoded credentials in Helpdesk (critical 9.8)
- [CVE-2018-0714](https://insights.sbomify.com/CVE-2018-0714/): Command injection in Helpdesk in QTS (critical 9.8)
- [CVE-2021-28814](https://insights.sbomify.com/CVE-2021-28814/): Improper Access Control Vulnerability in Helpdesk (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19947 and fix it if it is affected.

What it is: CVE-2018-19947 is a medium-severity vulnerability in QNAP Systems Inc. Helpdesk, published on 11 Sep 2020. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-19947 in the wild and no public exploit code.

Affected product: QNAP Systems Inc. Helpdesk. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19947/ (Markdown: https://insights.sbomify.com/CVE-2018-19947/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19947
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19947
- OSV: https://osv.dev/vulnerability/CVE-2018-19947

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19947/
Summaries are generated and may contain mistakes; the official description above is the record.
