# CVE-2018-19968: phpMyAdmin Local file inclusion through transformation feature

> Authenticated attackers can leak local file contents via a flaw in the transformation feature of phpMyAdmin.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-19968, GHSA-xc97-r49q-cxgc, UBUNTU-CVE-2018-19968

## What is CVE-2018-19968?

CVE-2018-19968 is a medium-severity vulnerability in Debian Debian Linux, published on 11 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An attacker can exploit phpMyAdmin before 4.8.4 to leak the contents of a local file because of an error in the transformation feature. The attacker must have access to the phpMyAdmin Configuration Storage tables, although these can easily be created in any database to which the attacker has access. An attacker must have valid credentials to log in to phpMyAdmin; this vulnerability does not allow an attacker to circumvent the login system.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-19968?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 4.8.4 |
| `phpmyadmin/phpmyadmin` | Packagist | All versions | 4.8.4 |

Products: Debian Debian Linux, Phpmyadmin Phpmyadmin.

## How do I fix CVE-2018-19968?

Upgrade phpmyadmin/phpmyadmin to 4.8.4 or later.

## Is CVE-2018-19968 being exploited?

There is no known exploitation of CVE-2018-19968 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19968 and fix it if it is affected.

What it is: CVE-2018-19968 is a medium-severity vulnerability in Debian Debian Linux, published on 11 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-19968 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 4.8.4
- phpmyadmin/phpmyadmin (Packagist): affected all versions; fixed in 4.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19968/ (Markdown: https://insights.sbomify.com/CVE-2018-19968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19968
- OSV: https://osv.dev/vulnerability/CVE-2018-19968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19968/
Summaries are generated and may contain mistakes; the official description above is the record.
