CVE-2018-19969 phpMyAdmin CSRF Vulnerability
Attackers can trick users into performing harmful SQL operations like renaming databases or changing passwords via crafted URLs.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-19969?
CVE-2018-19969 is a high-severity vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.
Weakness: CWE-352
Which versions are affected by CVE-2018-19969?
4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
phpmyadmin/phpmyadmin Packagist | From 4.7 to 4.7.6 | None |
phpmyadmin/phpmyadmin Packagist | From 4.7 to 4.7.6 | None |
phpmyadmin/phpmyadmin Packagist | From 4.8 | 4.8.4 |
phpmyadmin/phpmyadmin Packagist | From 4.8 | 4.8.4 |
Products include Phpmyadmin Phpmyadmin.
How do I fix CVE-2018-19969?
Upgrade phpmyadmin/phpmyadmin to 4.8.4 or later.
Is CVE-2018-19969 being exploited?
There is no known exploitation of CVE-2018-19969 in the wild and no public exploit code.
Other vulnerabilities in Phpmyadmin Phpmyadmin
Sources
Also known as DEBIAN-CVE-2018-19969, GHSA-xwf2-53mc-r8hx, UBUNTU-CVE-2018-19969.