# CVE-2018-19969: phpMyAdmin CSRF Vulnerability

> Attackers can trick users into performing harmful SQL operations like renaming databases or changing passwords via crafted URLs.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-19969, GHSA-xwf2-53mc-r8hx, UBUNTU-CVE-2018-19969

## What is CVE-2018-19969?

CVE-2018-19969 is a high-severity vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2018-19969?

4 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.7 to 4.7.6 | None |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.7 to 4.7.6 | None |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.8 | 4.8.4 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.8 | 4.8.4 |

Products: Phpmyadmin Phpmyadmin.

## How do I fix CVE-2018-19969?

Upgrade phpmyadmin/phpmyadmin to 4.8.4 or later.

## Is CVE-2018-19969 being exploited?

There is no known exploitation of CVE-2018-19969 in the wild and no public exploit code.

## Other vulnerabilities in Phpmyadmin Phpmyadmin

- [CVE-2008-7251](https://insights.sbomify.com/CVE-2008-7251/): Misconfiguration in n/a (critical 10.0)
- [CVE-2008-7252](https://insights.sbomify.com/CVE-2008-7252/): phpMyAdmin unsafely handles temporary files (critical 10.0)
- [CVE-2007-0203](https://insights.sbomify.com/CVE-2007-0203/): Other in n/a (critical 10.0)
- [CVE-2004-1147](https://insights.sbomify.com/CVE-2004-1147/): Command injection in n/a (critical 10.0)
- [CVE-2020-22452](https://insights.sbomify.com/CVE-2020-22452/): phpmyadmin contains SQL Injection vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19969 and fix it if it is affected.

What it is: CVE-2018-19969 is a high-severity vulnerability in Phpmyadmin Phpmyadmin, published on 11 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-19969 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.7 up to 4.7.6; no fix listed
- phpmyadmin/phpmyadmin (Packagist): affected from 4.7 up to 4.7.6; no fix listed
- phpmyadmin/phpmyadmin (Packagist): affected from 4.8; fixed in 4.8.4
- phpmyadmin/phpmyadmin (Packagist): affected from 4.8; fixed in 4.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19969/ (Markdown: https://insights.sbomify.com/CVE-2018-19969/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19969
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19969
- OSV: https://osv.dev/vulnerability/CVE-2018-19969

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19969/
Summaries are generated and may contain mistakes; the official description above is the record.
