# CVE-2018-19970: phpMyAdmin Cross-site Scripting (XSS) vulnerability

> An attacker can execute arbitrary scripts in a victim's browser via crafted database or table names in phpMyAdmin's navigation tree.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-19970, GHSA-8987-93fh-rcwq, UBUNTU-CVE-2018-19970

## What is CVE-2018-19970?

CVE-2018-19970 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 11 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In phpMyAdmin before 4.8.4, an XSS vulnerability was found in the navigation tree, where an attacker can deliver a payload to a user through a crafted database/table name.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-19970?

2 open source packages ship an affected version, including phpmyadmin/phpmyadmin. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.8.4 |
| `phpmyadmin/phpmyadmin` | Packagist | From 4.0 | 4.8.4 |

Products: Debian Debian Linux, Phpmyadmin Phpmyadmin.

## How do I fix CVE-2018-19970?

Upgrade phpmyadmin/phpmyadmin to 4.8.4 or later.

## Is CVE-2018-19970 being exploited?

There is no known exploitation of CVE-2018-19970 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-19970 and fix it if it is affected.

What it is: CVE-2018-19970 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 11 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-19970 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.8.4
- phpmyadmin/phpmyadmin (Packagist): affected from 4.0; fixed in 4.8.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-19970/ (Markdown: https://insights.sbomify.com/CVE-2018-19970/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-19970
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-19970
- OSV: https://osv.dev/vulnerability/CVE-2018-19970

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-19970/
Summaries are generated and may contain mistakes; the official description above is the record.
