# CVE-2018-1999002: Improper Input Validation in Jenkins

> Attackers can read arbitrary files on the Jenkins master file system via crafted HTTP requests in the Stapler framework.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-qf38-f2fr-q4x9

## What is CVE-2018-1999002?

CVE-2018-1999002 is a high-severity path traversal vulnerability in Jenkins Jenkins, published on 23 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A arbitrary file read vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in the Stapler web framework's org/kohsuke/stapler/Stapler.java that allows attackers to send crafted HTTP requests returning the contents of any file on the Jenkins master file system that the Jenkins master has access to.

## Which versions are affected by CVE-2018-1999002?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.121.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.121.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.122 | 2.132 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.122 | 2.132 |

Products: Jenkins Jenkins, Oracle Communications Cloud Native Core Automated Test Suite.

## How do I fix CVE-2018-1999002?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.121.2 or 2.132.

## Is CVE-2018-1999002 being exploited?

There is no known exploitation of CVE-2018-1999002 in the wild and no public exploit code.

Public exploit code:

- CVE-2020-8012, CVE-2016-10709, CVE-2017-17099, CVE-2017-18047, CVE-2019-1003000, CVE-2018-1999002 (github_poc): https://github.com/wetw0rk/Exploit-Development
- https://github.com/0x6b7966/CVE-2018-1999002 (github_poc): https://github.com/0x6b7966/CVE-2018-1999002
- Jenkins Plugin Script Security 1.49/Declarative 1.3.4/Groovy 2.60 - Remote Code Execution (exploitdb)
- Python CVE-2019-1003000 and CVE-2018-1999002 Pre-Auth RCE Jenkins  (github_poc): https://github.com/im23pds/CVE-2019-1003000-and-CVE-2018-1999002-Pre-Auth-RCE-Jenkins

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1999002 and fix it if it is affected.

What it is: CVE-2018-1999002 is a high-severity path traversal vulnerability in Jenkins Jenkins, published on 23 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1999002 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.121.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.121.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.122; fixed in 2.132
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.122; fixed in 2.132

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1999002/ (Markdown: https://insights.sbomify.com/CVE-2018-1999002/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1999002
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1999002
- OSV: https://osv.dev/vulnerability/CVE-2018-1999002

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1999002/
Summaries are generated and may contain mistakes; the official description above is the record.
