CVE-2018-1999004 Incorrect Authorization in Jenkins

Medium 4.3 Published Updated

Attackers with read permissions can launch or abort Jenkins agents, potentially causing denial of service or unauthorized resource usage.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1999004?

CVE-2018-1999004 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 23 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in SlaveComputer.java that allows attackers with Overall/Read permission to initiate agent launches, and abort in-progress agent launches.

Weakness: CWE-863

Which versions are affected by CVE-2018-1999004?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.121.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.121.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.1222.132
org.jenkins-ci.main:jenkins-core MavenFrom 2.1222.132

Products include Jenkins Jenkins, Oracle Communications Cloud Native Core Automated Test Suite.

How do I fix CVE-2018-1999004?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.121.2 or 2.132.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2018-1999004 being exploited?

There is no known exploitation of CVE-2018-1999004 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-wmr8-25ff-ggpj.

Is CVE-2018-1999004 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free