CVE-2018-1999006 Exposure of Sensitive Information to an Unauthorized Actor in Jenkins

Medium 4.3 Published Updated

Attackers can determine the last extraction date of Jenkins plugins, revealing installation or upgrade timelines.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1999006?

CVE-2018-1999006 is a medium-severity vulnerability in Jenkins Jenkins, published on 23 Jul 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A exposure of sensitive information vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in Plugin.java that allows attackers to determine the date and time when a plugin HPI/JPI file was last extracted, which typically is the date of the most recent installation/upgrade.

Weakness: CWE-200

Which versions are affected by CVE-2018-1999006?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.121.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.121.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.1222.132
org.jenkins-ci.main:jenkins-core MavenFrom 2.1222.132

Products include Jenkins Jenkins.

How do I fix CVE-2018-1999006?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.121.2 or 2.132.

Is CVE-2018-1999006 being exploited?

There is no known exploitation of CVE-2018-1999006 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-2pp9-r4rv-6p6j.

Is CVE-2018-1999006 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free