CVE-2018-1999007 Cross-site scripting vulnerability exists in Jenkins and Stapler Plugin
Attackers can execute arbitrary JavaScript in victims' browsers via crafted URLs on 404 pages when Stapler debug mode is enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-1999007?
CVE-2018-1999007 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 23 Jul 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
A cross-site scripting vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in the Stapler web framework's org/kohsuke/stapler/Stapler.java that allows attackers with the ability to control the existence of some URLs in Jenkins to define JavaScript that would be executed in another user's browser when that other user views HTTP 404 error pages while Stapler debug mode is enabled.
Weakness: CWE-79
Which versions are affected by CVE-2018-1999007?
6 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and org.kohsuke.stapler:stapler-parent. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.121.2 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.121.2 |
org.jenkins-ci.main:jenkins-core Maven | From 2.122 | 2.132 |
org.jenkins-ci.main:jenkins-core Maven | From 2.122 | 2.132 |
org.kohsuke.stapler:stapler-parent Maven | All versions | 1.250.1 |
org.kohsuke.stapler:stapler-parent Maven | All versions | 1.250.1 |
Products include Jenkins Jenkins, Oracle Communications Cloud Native Core Automated Test Suite.
How do I fix CVE-2018-1999007?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.121.2 or 2.132.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-1999007 being exploited?
There is no known exploitation of CVE-2018-1999007 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as GHSA-6456-xjm5-g3pg.