# CVE-2018-1999009: October CMS Local File Inclusion

> Remote attackers can exploit a Local File Inclusion flaw in October CMS to disclose sensitive information and execute arbitrary code if the backend is accessible.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jul 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-v7cr-w5v6-6659

## What is CVE-2018-1999009?

CVE-2018-1999009 is a high-severity path traversal vulnerability in Octobercms October, published on 23 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

October CMS version prior to Build 437 contains a Local File Inclusion vulnerability in modules/system/traits/ViewMaker.php#244 (makeFileContents function) that can result in Sensitive information disclosure and remote code execution. This attack appear to be exploitable remotely if the /backend path is accessible. This vulnerability appears to have been fixed in Build 437.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-1999009?

2 open source packages ship an affected version, including october/october. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `october/october` | Packagist | All versions | 1.0.437 |
| `october/october` | Packagist | All versions | 1.0.437 |

Products: Octobercms October.

## How do I fix CVE-2018-1999009?

Upgrade october/october to 1.0.437 or later.

## Is CVE-2018-1999009 being exploited?

There is no known exploitation of CVE-2018-1999009 in the wild and no public exploit code.

## Other vulnerabilities in Octobercms October

- [CVE-2021-32648](https://insights.sbomify.com/CVE-2021-32648/): October CMS Improper Authentication (high 8.2, exploited in the wild)
- [CVE-2021-3311](https://insights.sbomify.com/CVE-2021-3311/): October CMS Session ID not invalidated after logout (critical 9.8)
- [CVE-2017-1000194](https://insights.sbomify.com/CVE-2017-1000194/): October CMS File Upload Vulnerability (critical 9.8)
- [CVE-2017-1000196](https://insights.sbomify.com/CVE-2017-1000196/): Code injection in n/a (critical 9.8)
- [CVE-2017-1000197](https://insights.sbomify.com/CVE-2017-1000197/): Path traversal in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1999009 and fix it if it is affected.

What it is: CVE-2018-1999009 is a high-severity path traversal vulnerability in Octobercms October, published on 23 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1999009 in the wild and no public exploit code.

Affected packages and fixed versions:
- october/october (Packagist): affected all versions; fixed in 1.0.437
- october/october (Packagist): affected all versions; fixed in 1.0.437

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1999009/ (Markdown: https://insights.sbomify.com/CVE-2018-1999009/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1999009
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1999009
- OSV: https://osv.dev/vulnerability/CVE-2018-1999009

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1999009/
Summaries are generated and may contain mistakes; the official description above is the record.
