CVE-2018-1999016 Cross-site scripting in n/a

Medium 6.1 Published Updated

Unauthenticated attackers can inject malicious scripts via crafted URLs in Pydio, potentially compromising user sessions and data.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2018-1999016?

CVE-2018-1999016 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Pydio version 8.2.0 and earlier contains a Cross Site Scripting (XSS) vulnerability in ./core/vendor/meenie/javascript-packer/example-inline.php line 48; ./core/vendor/dapphp/securimage/examples/test.mysql.static.php lines: 114,118 that can result in an unauthenticated remote attacker manipulating the web client via XSS code injection. This attack appear to be exploitable via the victim openning a specially crafted URL. This vulnerability appears to have been fixed in version 8.2.1.

Weakness: CWE-79

Which versions are affected by CVE-2018-1999016?

It affects 1 product.

Products include Pydio Pydio.

How do I fix CVE-2018-1999016?

No fix has been published for CVE-2018-1999016 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-1999016 being exploited?

There is no known exploitation of CVE-2018-1999016 in the wild and no public exploit code.

Sources

Also known as GHSA-wjmj-fqjq-3hfp.

Is CVE-2018-1999016 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free