CVE-2018-1999017 Server-side request forgery in n/a

Medium 4.9 Published Updated

An authenticated admin can trigger SSRF via the Upgrade Engine, allowing arbitrary URL requests and potential internal network pivoting.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2018-1999017?

CVE-2018-1999017 is a medium-severity server-side request forgery vulnerability in n/a, published on 23 Jul 2018. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Pydio version 8.2.0 and earlier contains a Server-Side Request Forgery (SSRF) vulnerability in plugins/action.updater/UpgradeManager.php Line: 154, getUpgradePath($url) that can result in an authenticated admin users requesting arbitrary URL's, pivoting requests through the server. This attack appears to be exploitable via the attacker gaining access to an administrative account, enters a URL into Upgrade Engine, and reloads the page or presses "Check Now". This vulnerability appears to have been fixed in 8.2.1.

Weakness: CWE-918

Which versions are affected by CVE-2018-1999017?

It affects 1 product.

Products include Pydio Pydio.

How do I fix CVE-2018-1999017?

No fix has been published for CVE-2018-1999017 yet. Limit exposure of the affected software until one is available.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2018-1999017 being exploited?

There is no known exploitation of CVE-2018-1999017 in the wild and no public exploit code.

Sources

Also known as GHSA-528p-fqc4-66rm.

Is CVE-2018-1999017 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free