{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1999017 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2018-1999017 yet. Limit exposure of the affected software until one is available.","what":"CVE-2018-1999017 is a medium-severity server-side request forgery vulnerability in n/a, published on 23 Jul 2018. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1999017 and fix it if it is affected.\n\nWhat it is: CVE-2018-1999017 is a medium-severity server-side request forgery vulnerability in n/a, published on 23 Jul 2018. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1999017 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1999017/ (Markdown: https://insights.sbomify.com/CVE-2018-1999017/index.md)","id":"CVE-2018-1999017","markdown":"https://insights.sbomify.com/CVE-2018-1999017/index.md","name":"CVE-2018-1999017","record":{"aliases":["GHSA-528p-fqc4-66rm"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Pydio file sharing","requires_auth":"high_privilege","summary":"An authenticated admin can trigger SSRF via the Upgrade Engine, allowing arbitrary URL requests and potential internal network pivoting.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pydio","vendor":"pydio"}],"cvss":{"score":4.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"Pydio version 8.2.0 and earlier contains a Server-Side Request Forgery (SSRF) vulnerability in plugins/action.updater/UpgradeManager.php Line: 154, getUpgradePath($url) that can result in an authenticated admin users requesting arbitrary URL's, pivoting requests through the server. This attack appears to be exploitable via the attacker gaining access to an administrative account, enters a URL into Upgrade Engine, and reloads the page or presses \"Check Now\". This vulnerability appears to have been fixed in 8.2.1.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Server-side request forgery in n/a","id":"CVE-2018-1999017","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"ssrf","year":"2018"},"n_packages":0,"n_references":2,"next":{"headline":"Command injection in n/a","id":"CVE-2018-1999018"},"packages":[],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-1999016"},"products":["n/a"],"published":"2018-07-23","related":[{"cvss_score":9.8,"headline":"Command injection in Ajaxeplorer","id":"CVE-2013-4267","kev_date_added":null,"published":"2020-02-11"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-9642","kev_date_added":null,"published":"2019-06-05"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2018-20718","kev_date_added":null,"published":"2019-01-15"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2015-3431","kev_date_added":null,"published":"2017-09-19"},{"cvss_score":8.8,"headline":"Deserialization in n/a","id":"CVE-2019-20452","kev_date_added":null,"published":"2020-03-17"},{"cvss_score":8.8,"headline":"Deserialization in n/a","id":"CVE-2019-20453","kev_date_added":null,"published":"2020-03-17"},{"cvss_score":7.7,"headline":"Server-side request forgery in n/a","id":"CVE-2019-15033","kev_date_added":null,"published":"2019-09-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An authenticated admin can trigger SSRF via the Upgrade Engine, allowing arbitrary URL requests and potential internal network pivoting.","url":"https://insights.sbomify.com/CVE-2018-1999017/"}