# CVE-2018-1999017: Server-side request forgery in n/a

> An authenticated admin can trigger SSRF via the Upgrade Engine, allowing arbitrary URL requests and potential internal network pivoting.

- **Severity:** Medium 4.9 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 23 Jul 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-528p-fqc4-66rm

## What is CVE-2018-1999017?

CVE-2018-1999017 is a medium-severity server-side request forgery vulnerability in n/a, published on 23 Jul 2018. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Pydio version 8.2.0 and earlier contains a Server-Side Request Forgery (SSRF) vulnerability in plugins/action.updater/UpgradeManager.php Line: 154, getUpgradePath($url) that can result in an authenticated admin users requesting arbitrary URL's, pivoting requests through the server. This attack appears to be exploitable via the attacker gaining access to an administrative account, enters a URL into Upgrade Engine, and reloads the page or presses "Check Now". This vulnerability appears to have been fixed in 8.2.1.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2018-1999017?

It affects 1 product.


Products: Pydio Pydio.

## How do I fix CVE-2018-1999017?

No fix has been published for CVE-2018-1999017 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-1999017 being exploited?

There is no known exploitation of CVE-2018-1999017 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2013-4267](https://insights.sbomify.com/CVE-2013-4267/): Command injection in Ajaxeplorer (critical 9.8)
- [CVE-2019-9642](https://insights.sbomify.com/CVE-2019-9642/): Code injection in n/a (critical 9.8)
- [CVE-2018-20718](https://insights.sbomify.com/CVE-2018-20718/): Deserialization in n/a (critical 9.8)
- [CVE-2015-3431](https://insights.sbomify.com/CVE-2015-3431/): Command injection in n/a (critical 9.8)
- [CVE-2019-20452](https://insights.sbomify.com/CVE-2019-20452/): Deserialization in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1999017 and fix it if it is affected.

What it is: CVE-2018-1999017 is a medium-severity server-side request forgery vulnerability in n/a, published on 23 Jul 2018. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1999017 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1999017/ (Markdown: https://insights.sbomify.com/CVE-2018-1999017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1999017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1999017
- OSV: https://osv.dev/vulnerability/CVE-2018-1999017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1999017/
Summaries are generated and may contain mistakes; the official description above is the record.
