# CVE-2018-1999024: Macro in MathJax running untrusted Javascript within a web browser

> An XSS vulnerability in MathJax allows attackers to execute arbitrary JavaScript in a victim's browser via the unicode macro.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jul 2018
- **Updated:** 16 Sep 2024
- **Also known as:** AZL-41294, CVE-2018-1000214, DEBIAN-CVE-2018-1999024, GHSA-3c48-6pcv-88rm, UBUNTU-CVE-2018-1999024

## What is CVE-2018-1999024?

CVE-2018-1999024 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

MathJax version prior to version 2.7.4 contains a Cross Site Scripting (XSS) vulnerability in the \unicode{} macro that can result in Potentially untrusted Javascript running within a web browser. This attack appear to be exploitable via The victim must view a page where untrusted content is processed using Mathjax. This vulnerability appears to have been fixed in 2.7.4 and later.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-1999024?

2 open source packages ship an affected version, including mathjax. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mathjax` | npm | All versions | 2.7.4 |
| `mathjax` | npm | All versions | 2.7.4 |

Products: Mathjax Mathjax.

## How do I fix CVE-2018-1999024?

Upgrade mathjax to 2.7.4 or later.

## Is CVE-2018-1999024 being exploited?

There is no known exploitation of CVE-2018-1999024 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-39663](https://insights.sbomify.com/CVE-2023-39663/): MathJax Regular expression Denial of Service (ReDoS) (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1999024 and fix it if it is affected.

What it is: CVE-2018-1999024 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1999024 in the wild and no public exploit code.

Affected packages and fixed versions:
- mathjax (npm): affected all versions; fixed in 2.7.4
- mathjax (npm): affected all versions; fixed in 2.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1999024/ (Markdown: https://insights.sbomify.com/CVE-2018-1999024/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1999024
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1999024
- OSV: https://osv.dev/vulnerability/CVE-2018-1999024

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1999024/
Summaries are generated and may contain mistakes; the official description above is the record.
