# CVE-2018-1999026: Jenkins TraceTronic ECU-TEST Plugin server-side request forgery vulnerability

> Attackers can force Jenkins to send HTTP requests to arbitrary hosts via the TraceTronic ECU-TEST plugin, potentially accessing internal resources.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hp7x-282p-hhr9

## What is CVE-2018-1999026?

CVE-2018-1999026 is a medium-severity server-side request forgery vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A server-side request forgery vulnerability exists in Jenkins TraceTronic ECU-TEST Plugin 2.3 and earlier in ATXPublisher.java that allows attackers to have Jenkins send HTTP requests to an attacker-specified host.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2018-1999026?

2 open source packages ship an affected version, including de.tracetronic.jenkins.plugins:ecutest. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `de.tracetronic.jenkins.plugins:ecutest` | Maven | All versions | 2.4 |
| `de.tracetronic.jenkins.plugins:ecutest` | Maven | All versions | 2.4 |

Products: Jenkins Tracetronic Ecu-Test.

## How do I fix CVE-2018-1999026?

Upgrade de.tracetronic.jenkins.plugins:ecutest to 2.4 or later.

## Is CVE-2018-1999026 being exploited?

There is no known exploitation of CVE-2018-1999026 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1999025](https://insights.sbomify.com/CVE-2018-1999025/): Jenkins TraceTronic ECU-TEST Plugin Man in the middle vulnerability (high 7.4)
- [CVE-2021-21612](https://insights.sbomify.com/CVE-2021-21612/): Credentials stored in plain text by Jenkins TraceTronic ECU-TEST Plugin (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1999026 and fix it if it is affected.

What it is: CVE-2018-1999026 is a medium-severity server-side request forgery vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1999026 in the wild and no public exploit code.

Affected packages and fixed versions:
- de.tracetronic.jenkins.plugins:ecutest (Maven): affected all versions; fixed in 2.4
- de.tracetronic.jenkins.plugins:ecutest (Maven): affected all versions; fixed in 2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1999026/ (Markdown: https://insights.sbomify.com/CVE-2018-1999026/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1999026
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1999026
- OSV: https://osv.dev/vulnerability/CVE-2018-1999026

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1999026/
Summaries are generated and may contain mistakes; the official description above is the record.
