{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:accurev. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1999028 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:accurev to 0.7.17 or later.","what":"CVE-2018-1999028 is a high-severity vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1999028 and fix it if it is affected.\n\nWhat it is: CVE-2018-1999028 is a high-severity vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1999028 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:accurev (Maven): affected all versions; fixed in 0.7.17\n- org.jenkins-ci.plugins:accurev (Maven): affected all versions; fixed in 0.7.17\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1999028/ (Markdown: https://insights.sbomify.com/CVE-2018-1999028/index.md)","id":"CVE-2018-1999028","markdown":"https://insights.sbomify.com/CVE-2018-1999028/index.md","name":"CVE-2018-1999028","record":{"aliases":["GHSA-8vg7-gh73-866v"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Accurev Plugin","requires_auth":"low_privilege","summary":"Attackers can capture credentials with a known ID from the Jenkins Accurev Plugin, exposing sensitive authentication data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"accurev","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"An exposure of sensitive information vulnerability exists in Jenkins Accurev Plugin 0.7.16 and earlier in AccurevSCM.java that allows attackers to capture credentials with a known credentials ID stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Accurev Plugin CSRF vulnerability and missing permission checks","id":"CVE-2018-1999028","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Stored Cross-Site Scripting Vulnerability in Jenkins Shelve Project Plugin","id":"CVE-2018-1999029"},"packages":[{"ecosystem":"Maven","fixed":["0.7.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:accurev","purl":null,"source":"GHSA-8vg7-gh73-866v"},{"ecosystem":"Maven","fixed":["0.7.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:accurev","purl":"pkg:maven/org.jenkins-ci.plugins/accurev","source":"GHSA-8vg7-gh73-866v"}],"prev":{"headline":"Jenkins SaltStack Plugin allows attackers to capture credentials with a known credentials ID stored in Jenkins","id":"CVE-2018-1999027"},"products":["n/a"],"published":"2018-08-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can capture credentials with a known ID from the Jenkins Accurev Plugin, exposing sensitive authentication data.","url":"https://insights.sbomify.com/CVE-2018-1999028/"}