{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:maven-artifact-choicelistprovider. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1999030 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:maven-artifact-choicelistprovider to 1.3.2 or later.","what":"CVE-2018-1999030 is a medium-severity vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1999030 and fix it if it is affected.\n\nWhat it is: CVE-2018-1999030 is a medium-severity vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1999030 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:maven-artifact-choicelistprovider (Maven): affected all versions; fixed in 1.3.2\n- org.jenkins-ci.plugins:maven-artifact-choicelistprovider (Maven): affected all versions; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1999030/ (Markdown: https://insights.sbomify.com/CVE-2018-1999030/index.md)","id":"CVE-2018-1999030","markdown":"https://insights.sbomify.com/CVE-2018-1999030/index.md","name":"CVE-2018-1999030","record":{"aliases":["GHSA-fjh2-qhfh-rvfc"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Maven plugin","requires_auth":"low_privilege","summary":"Attackers can capture credentials with known IDs from Jenkins Maven Artifact ChoiceListProvider plugin, exposing sensitive authentication data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"maven_artifact_choicelistprovider_\\(nexus\\)","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"An exposure of sensitive information vulnerability exists in Jenkins Maven Artifact ChoiceListProvider (Nexus) Plugin 1.3.1 and earlier in ArtifactoryChoiceListProvider.java, NexusChoiceListProvider.java, Nexus3ChoiceListProvider.java that allows attackers to capture credentials with a known credentials ID stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Maven Artifact ChoiceListProvider (Nexus) Plugin CSRF vulnerability and missing permission checks","id":"CVE-2018-1999030","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins meliora-testlab Plugin allows attackers with file system access to Jenkins master to obtain API key","id":"CVE-2018-1999031"},"packages":[{"ecosystem":"Maven","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:maven-artifact-choicelistprovider","purl":null,"source":"GHSA-fjh2-qhfh-rvfc"},{"ecosystem":"Maven","fixed":["1.3.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:maven-artifact-choicelistprovider","purl":"pkg:maven/org.jenkins-ci.plugins/maven-artifact-choicelistprovider","source":"GHSA-fjh2-qhfh-rvfc"}],"prev":{"headline":"Stored Cross-Site Scripting Vulnerability in Jenkins Shelve Project Plugin","id":"CVE-2018-1999029"},"products":["n/a"],"published":"2018-08-01","related":[{"cvss_score":6.5,"headline":"Jenkins Maven Artifact ChoiceListProvider (Nexus) Plugin vulnerable to exposure of system-scoped credentials","id":"CVE-2023-40347","kev_date_added":null,"published":"2023-08-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers can capture credentials with known IDs from Jenkins Maven Artifact ChoiceListProvider plugin, exposing sensitive authentication data.","url":"https://insights.sbomify.com/CVE-2018-1999030/"}