# CVE-2018-1999031: Jenkins meliora-testlab Plugin allows attackers with file system access to Jenkins master to obtain API key

> Attackers with file system access to the Jenkins master can obtain the API key stored in the meliora-testlab plugin configuration.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-3hw6-gc8h-9243

## What is CVE-2018-1999031?

CVE-2018-1999031 is a medium-severity vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An exposure of sensitive information vulnerability exists in Jenkins meliora-testlab Plugin 1.14 and earlier in TestlabNotifier.java that allows attackers with file system access to the Jenkins master to obtain the API key stored in this plugin's configuration.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-1999031?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:meliora-testlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:meliora-testlab` | Maven | All versions | 1.15 |
| `org.jenkins-ci.plugins:meliora-testlab` | Maven | All versions | 1.15 |

Products: Jenkins Meliora Testlab.

## How do I fix CVE-2018-1999031?

Upgrade org.jenkins-ci.plugins:meliora-testlab to 1.15 or later.

## Is CVE-2018-1999031 being exploited?

There is no known exploitation of CVE-2018-1999031 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1999031 and fix it if it is affected.

What it is: CVE-2018-1999031 is a medium-severity vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1999031 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:meliora-testlab (Maven): affected all versions; fixed in 1.15
- org.jenkins-ci.plugins:meliora-testlab (Maven): affected all versions; fixed in 1.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1999031/ (Markdown: https://insights.sbomify.com/CVE-2018-1999031/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1999031
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1999031
- OSV: https://osv.dev/vulnerability/CVE-2018-1999031

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1999031/
Summaries are generated and may contain mistakes; the official description above is the record.
