# CVE-2018-1999036: Jenkins SSH Agent Plugin exposes SSH private key password to users with permission to read the build log

> Attackers with build log read access can view exposed SSH private key passwords in Jenkins SSH Agent Plugin.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-wwgx-94v6-fc2p

## What is CVE-2018-1999036?

CVE-2018-1999036 is a medium-severity vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An exposure of sensitive information vulnerability exists in Jenkins SSH Agent Plugin 1.15 and earlier in SSHAgentStepExecution.java that exposes the SSH private key password to users with permission to read the build log.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2018-1999036?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:ssh-agent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:ssh-agent` | Maven | All versions | 1.16 |
| `org.jenkins-ci.plugins:ssh-agent` | Maven | All versions | 1.16 |

Products: Jenkins Ssh Agent.

## How do I fix CVE-2018-1999036?

Upgrade org.jenkins-ci.plugins:ssh-agent to 1.16 or later.

## Is CVE-2018-1999036 being exploited?

There is no known exploitation of CVE-2018-1999036 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-20620](https://insights.sbomify.com/CVE-2022-20620/): Missing permission checks in SSH Agent Plugin allow enumerating credentials IDs (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1999036 and fix it if it is affected.

What it is: CVE-2018-1999036 is a medium-severity vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1999036 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:ssh-agent (Maven): affected all versions; fixed in 1.16
- org.jenkins-ci.plugins:ssh-agent (Maven): affected all versions; fixed in 1.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1999036/ (Markdown: https://insights.sbomify.com/CVE-2018-1999036/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1999036
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1999036
- OSV: https://osv.dev/vulnerability/CVE-2018-1999036

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1999036/
Summaries are generated and may contain mistakes; the official description above is the record.
