# CVE-2018-1999038: Jenkins Publisher Over CIFS Plugin confused deputy vulnerability

> Attackers can force Jenkins to connect to malicious CIFS servers using attacker-controlled credentials, potentially exposing sensitive data or bypassing security controls.

- **Severity:** Medium 4.2 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-rf7h-9m85-535v

## What is CVE-2018-1999038?

CVE-2018-1999038 is a medium-severity server-side request forgery vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A confused deputy vulnerability exists in Jenkins Publisher Over CIFS Plugin 0.10 and earlier in CifsPublisherPluginDescriptor.java that allows attackers to have Jenkins connect to an attacker specified CIFS server with attacker specified credentials.

Weakness: CWE-441 (Unintended Proxy or Intermediary)

## Which versions are affected by CVE-2018-1999038?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:publish-over-cifs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:publish-over-cifs` | Maven | All versions | 0.11 |
| `org.jenkins-ci.plugins:publish-over-cifs` | Maven | All versions | 0.11 |

Products: Jenkins Publish Over Cifs.

## How do I fix CVE-2018-1999038?

Upgrade org.jenkins-ci.plugins:publish-over-cifs to 0.11 or later.

## Is CVE-2018-1999038 being exploited?

There is no known exploitation of CVE-2018-1999038 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1999038 and fix it if it is affected.

What it is: CVE-2018-1999038 is a medium-severity server-side request forgery vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1999038 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:publish-over-cifs (Maven): affected all versions; fixed in 0.11
- org.jenkins-ci.plugins:publish-over-cifs (Maven): affected all versions; fixed in 0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1999038/ (Markdown: https://insights.sbomify.com/CVE-2018-1999038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1999038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1999038
- OSV: https://osv.dev/vulnerability/CVE-2018-1999038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1999038/
Summaries are generated and may contain mistakes; the official description above is the record.
