{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:confluence-publisher. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1999039 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:confluence-publisher to 2.0.2 or later.","what":"CVE-2018-1999039 is a medium-severity server-side request forgery vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1999039 and fix it if it is affected.\n\nWhat it is: CVE-2018-1999039 is a medium-severity server-side request forgery vulnerability in n/a, published on 1 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1999039 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:confluence-publisher (Maven): affected all versions; fixed in 2.0.2\n- org.jenkins-ci.plugins:confluence-publisher (Maven): affected all versions; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1999039/ (Markdown: https://insights.sbomify.com/CVE-2018-1999039/index.md)","id":"CVE-2018-1999039","markdown":"https://insights.sbomify.com/CVE-2018-1999039/index.md","name":"CVE-2018-1999039","record":{"aliases":["GHSA-5339-9974-hqj9"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Confluence Plugin","requires_auth":"low_privilege","summary":"Attackers can force Jenkins to send login requests to arbitrary Confluence servers, potentially exposing credentials or bypassing network restrictions.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"confluence_publisher","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"A server-side request forgery vulnerability exists in Jenkins Confluence Publisher Plugin 2.0.1 and earlier in ConfluenceSite.java that allows attackers to have Jenkins submit login requests to an attacker-specified Confluence server URL with attacker specified credentials.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server-Side Request Forgery (SSRF) in Jenkins Confluence Publisher Plugin","id":"CVE-2018-1999039","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Exposure of Sensitive Information in Jenkins Kubernetes Plugin","id":"CVE-2018-1999040"},"packages":[{"ecosystem":"Maven","fixed":["2.0.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:confluence-publisher","purl":null,"source":"GHSA-5339-9974-hqj9"},{"ecosystem":"Maven","fixed":["2.0.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:confluence-publisher","purl":"pkg:maven/org.jenkins-ci.plugins/confluence-publisher","source":"GHSA-5339-9974-hqj9"}],"prev":{"headline":"Jenkins Publisher Over CIFS Plugin confused deputy vulnerability","id":"CVE-2018-1999038"},"products":["n/a"],"published":"2018-08-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can force Jenkins to send login requests to arbitrary Confluence servers, potentially exposing credentials or bypassing network restrictions.","url":"https://insights.sbomify.com/CVE-2018-1999039/"}