CVE-2018-1999043 Missing Release of Resource after Effective Lifetime in Jenkins

High 7.5 Published Updated

Attackers can cause denial of service in Jenkins by creating ephemeral in-memory user records through repeated invalid login attempts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1999043?

CVE-2018-1999043 is a high-severity denial of service vulnerability in Jenkins Jenkins, published on 23 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A denial of service vulnerability exists in Jenkins 2.137 and earlier, 2.121.2 and earlier in BasicAuthenticationFilter.java, BasicHeaderApiTokenAuthenticator.java that allows attackers to create ephemeral in-memory user records by attempting to log in using invalid credentials.

Weakness: CWE-772

Which versions are affected by CVE-2018-1999043?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.121.3
org.jenkins-ci.main:jenkins-core MavenAll versions2.121.3
org.jenkins-ci.main:jenkins-core MavenFrom 2.1222.138
org.jenkins-ci.main:jenkins-core MavenFrom 2.1222.138

Products include Jenkins Jenkins.

How do I fix CVE-2018-1999043?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.121.3 or 2.138.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2018-1999043 being exploited?

There is no known exploitation of CVE-2018-1999043 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-2632-h32j-6rg9.

Is CVE-2018-1999043 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free