# CVE-2018-1999043: Missing Release of Resource after Effective Lifetime in Jenkins

> Attackers can cause denial of service in Jenkins by creating ephemeral in-memory user records through repeated invalid login attempts.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Aug 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-2632-h32j-6rg9

## What is CVE-2018-1999043?

CVE-2018-1999043 is a high-severity denial of service vulnerability in Jenkins Jenkins, published on 23 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A denial of service vulnerability exists in Jenkins 2.137 and earlier, 2.121.2 and earlier in BasicAuthenticationFilter.java, BasicHeaderApiTokenAuthenticator.java that allows attackers to create ephemeral in-memory user records by attempting to log in using invalid credentials.

Weakness: CWE-772 (Missing Release of Resource after Effective Lifetime)

## Which versions are affected by CVE-2018-1999043?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.121.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.121.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.122 | 2.138 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.122 | 2.138 |

Products: Jenkins Jenkins.

## How do I fix CVE-2018-1999043?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.121.3 or 2.138.

## Is CVE-2018-1999043 being exploited?

There is no known exploitation of CVE-2018-1999043 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1999043 and fix it if it is affected.

What it is: CVE-2018-1999043 is a high-severity denial of service vulnerability in Jenkins Jenkins, published on 23 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1999043 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.121.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.121.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.122; fixed in 2.138
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.122; fixed in 2.138

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1999043/ (Markdown: https://insights.sbomify.com/CVE-2018-1999043/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1999043
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1999043
- OSV: https://osv.dev/vulnerability/CVE-2018-1999043

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1999043/
Summaries are generated and may contain mistakes; the official description above is the record.
