CVE-2018-1999047 Incorrect Authorization in Jenkins

Medium 6.5 Published Updated

Attackers can cancel scheduled Jenkins restarts via the update center due to improper authorization checks in the UpdateCenter component.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1999047?

CVE-2018-1999047 is a medium-severity missing authorization vulnerability in Jenkins Jenkins, published on 23 Aug 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A improper authorization vulnerability exists in Jenkins 2.137 and earlier, 2.121.2 and earlier in UpdateCenter.java that allows attackers to cancel a Jenkins restart scheduled through the update center.

Weakness: CWE-863

Which versions are affected by CVE-2018-1999047?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.121.3
org.jenkins-ci.main:jenkins-core MavenAll versions2.121.3
org.jenkins-ci.main:jenkins-core MavenFrom 2.1222.138
org.jenkins-ci.main:jenkins-core MavenFrom 2.1222.138

Products include Jenkins Jenkins.

How do I fix CVE-2018-1999047?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.121.3 or 2.138.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2018-1999047 being exploited?

There is no known exploitation of CVE-2018-1999047 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-r2jf-rc5v-vmpv.

Is CVE-2018-1999047 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free