{"answers":{"affected":"2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-19994 in the wild and no public exploit code.","fix":"Upgrade dolibarr/dolibarr to 8.0.4 or later.","what":"CVE-2018-19994 is a high-severity SQL injection vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 3 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-19994 and fix it if it is affected.\n\nWhat it is: CVE-2018-19994 is a high-severity SQL injection vulnerability in Dolibarr Dolibarr Erp\\/Crm, published on 3 Jan 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-19994 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 8.0.4\n- dolibarr/dolibarr (Packagist): affected all versions; fixed in 8.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-19994/ (Markdown: https://insights.sbomify.com/CVE-2018-19994/index.md)","id":"CVE-2018-19994","markdown":"https://insights.sbomify.com/CVE-2018-19994/index.md","name":"CVE-2018-19994","record":{"aliases":["GHSA-78hj-952q-99rw","UBUNTU-CVE-2018-19994"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Dolibarr ERP/CRM","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary SQL commands via the desiredstock parameter in Dolibarr, potentially reading or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dolibarr_erp\\/crm","vendor":"dolibarr"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"An error-based SQL injection vulnerability in product/card.php in Dolibarr version 8.0.2 allows remote authenticated users to execute arbitrary SQL commands via the desiredstock parameter.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Dolibarr error-based SQL injection vulnerability in product/card.php","id":"CVE-2018-19994","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"dolibarr:dolibarr_erp\\/crm","products":["dolibarr:dolibarr_erp\\/crm"],"type":"sql_injection","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Dolibarr stored cross-site scripting (XSS) vulnerability","id":"CVE-2018-19995"},"packages":[{"ecosystem":"Packagist","fixed":["8.0.4"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":null,"source":"GHSA-78hj-952q-99rw"},{"ecosystem":"Packagist","fixed":["8.0.4"],"introduced":["0"],"last_affected":[],"package":"dolibarr/dolibarr","purl":"pkg:composer/dolibarr/dolibarr","source":"GHSA-78hj-952q-99rw"}],"prev":{"headline":"Dolibarr reflected cross-site scripting (XSS) vulnerability","id":"CVE-2018-19993"},"products":["n/a"],"published":"2019-01-03","related":[{"cvss_score":9.8,"headline":"Dolibarr vulnerable to privilege escalation","id":"CVE-2022-43138","kev_date_added":null,"published":"2022-11-17"},{"cvss_score":9.8,"headline":"Dolibarr vulnerable to Eval Injection","id":"CVE-2022-40871","kev_date_added":null,"published":"2022-10-12"},{"cvss_score":9.8,"headline":"Dolibarr remote PHP code execution","id":"CVE-2021-33816","kev_date_added":null,"published":"2021-11-10"},{"cvss_score":9.8,"headline":"Dolibarr Improper Restriction of Excessive Authentication Attempts","id":"CVE-2020-7995","kev_date_added":null,"published":"2020-01-26"},{"cvss_score":9.8,"headline":"SQL injection in dolibarr","id":"CVE-2013-2091","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Command injection in dolibarr","id":"CVE-2013-2093","kev_date_added":null,"published":"2019-11-20"},{"cvss_score":9.8,"headline":"Dolibarr SQL injection vulnerability in product/card.php","id":"CVE-2018-13447","kev_date_added":null,"published":"2018-07-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Authenticated attackers can execute arbitrary SQL commands via the desiredstock parameter in Dolibarr, potentially reading or modifying database contents.","url":"https://insights.sbomify.com/CVE-2018-19994/"}