# CVE-2018-20000: Improper Restriction of XML External Entity Reference in bedework:bw-webdav

> An attacker can exploit an XML External Entity vulnerability in Bedework to read local files via a crafted invite-reply document.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-5p52-j8pw-j7x5

## What is CVE-2018-20000?

CVE-2018-20000 is a high-severity vulnerability in n/a, published on 10 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apereo Bedework bw-webdav before 4.0.3 allows XXE attacks, as demonstrated by an invite-reply document that reads a local file, related to webdav/servlet/common/MethodBase.java and webdav/servlet/common/PostRequestPars.java.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2018-20000?

2 open source packages ship an affected version, including org.bedework:bw-webdav. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.bedework:bw-webdav` | Maven | From 4.0.1 | 4.0.3 |
| `org.bedework:bw-webdav` | Maven | From 4.0.1 | 4.0.3 |

Products: Apereo Bw-Webdav.

## How do I fix CVE-2018-20000?

Upgrade org.bedework:bw-webdav to 4.0.3 or later.

## Is CVE-2018-20000 being exploited?

There is no known exploitation of CVE-2018-20000 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20000 and fix it if it is affected.

What it is: CVE-2018-20000 is a high-severity vulnerability in n/a, published on 10 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20000 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.bedework:bw-webdav (Maven): affected from 4.0.1; fixed in 4.0.3
- org.bedework:bw-webdav (Maven): affected from 4.0.1; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20000/ (Markdown: https://insights.sbomify.com/CVE-2018-20000/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20000
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20000
- OSV: https://osv.dev/vulnerability/CVE-2018-20000

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20000/
Summaries are generated and may contain mistakes; the official description above is the record.
