CVE-2018-20028 Contao Information Disclosure via Access Control Flaws
Attackers can bypass access controls in Contao CMS to perform unauthorized actions due to incorrect access control implementation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-20028?
CVE-2018-20028 is a medium-severity missing authorization vulnerability in n/a, published on 17 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Contao 3.x before 3.5.37, 4.4.x before 4.4.31 and 4.6.x before 4.6.11 has Incorrect Access Control.
Which versions are affected by CVE-2018-20028?
6 open source packages ship an affected version, including contao/contao. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/contao Packagist | From 3.0.0 | 3.5.37 |
contao/contao Packagist | From 3.0.0 | 3.5.37 |
contao/contao Packagist | From 4.4.0 | 4.4.31 |
contao/contao Packagist | From 4.4.0 | 4.4.31 |
contao/contao Packagist | From 4.6.0 | 4.6.11 |
contao/contao Packagist | From 4.6.0 | 4.6.11 |
Products include Contao Contao Cms.
How do I fix CVE-2018-20028?
Upgrade contao/contao to a fixed version for your release line: 3.5.37, 4.4.31 or 4.6.11.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2018-20028 being exploited?
There is no known exploitation of CVE-2018-20028 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-q99w-j4mj-7hj8.