# CVE-2018-20060: Exposure of Sensitive Information to an Unauthorized Actor in urllib3

> Attackers can steal Authorization headers via cross-origin redirects in urllib3, exposing credentials to unintended hosts.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Dec 2018
- **Updated:** 27 Dec 2024
- **Also known as:** DEBIAN-CVE-2018-20060, GHSA-www2-v7xj-xrc6, MINI-jh32-6xj9-62q4, PYSEC-2018-32, ROOT-APP-PYPI-CVE-2018-20060, UBUNTU-CVE-2018-20060

## What is CVE-2018-20060?

CVE-2018-20060 is a critical vulnerability in Fedoraproject Fedora, published on 11 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

urllib3 before version 1.23 does not remove the Authorization HTTP header when following a cross-origin redirect (i.e., a redirect that differs in host, port, or scheme). This can allow for credentials in the Authorization header to be exposed to unintended hosts or transmitted in cleartext.

## Which versions are affected by CVE-2018-20060?

3 open source packages ship an affected version, including urllib3. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `urllib3` | PyPI | All versions | 1.23 |
| `urllib3` | PyPI | All versions | 1.23 |
| `urllib3` | PyPI | All versions | 1.23 |

Products: Fedoraproject Fedora, Python Urllib3.

## How do I fix CVE-2018-20060?

Upgrade urllib3 to 1.23 or later.

## Is CVE-2018-20060 being exploited?

There is no known exploitation of CVE-2018-20060 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-20060 and fix it if it is affected.

What it is: CVE-2018-20060 is a critical vulnerability in Fedoraproject Fedora, published on 11 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-20060 in the wild and no public exploit code.

Affected packages and fixed versions:
- urllib3 (PyPI): affected all versions; fixed in 1.23
- urllib3 (PyPI): affected all versions; fixed in 1.23
- urllib3 (PyPI): affected all versions; fixed in 1.23

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-20060/ (Markdown: https://insights.sbomify.com/CVE-2018-20060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-20060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-20060
- OSV: https://osv.dev/vulnerability/CVE-2018-20060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-20060/
Summaries are generated and may contain mistakes; the official description above is the record.
