{"answers":{"affected":"2 open source packages ship an affected version, including uap-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-20164 in the wild and no public exploit code.","fix":"Upgrade uap-core to 0.6.0 or later.","what":"CVE-2018-20164 is a medium-severity denial of service vulnerability in n/a, published on 13 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-20164 and fix it if it is affected.\n\nWhat it is: CVE-2018-20164 is a medium-severity denial of service vulnerability in n/a, published on 13 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-20164 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- uap-core (npm): affected all versions; fixed in 0.6.0\n- uap-core (npm): affected all versions; fixed in 0.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-20164/ (Markdown: https://insights.sbomify.com/CVE-2018-20164/index.md)","id":"CVE-2018-20164","markdown":"https://insights.sbomify.com/CVE-2018-20164/index.md","name":"CVE-2018-20164","record":{"aliases":["DEBIAN-CVE-2018-20164","GHSA-fx7m-j728-mjw3"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"User-Agent parsing library","requires_auth":"none","summary":"Remote attackers can cause server overload via ReDoS by sending crafted User-Agent headers to applications using the vulnerable UAP-Core library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"user_agent_parser-core","vendor":"uaparser"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.0"},"cwes":[{"id":"CWE-185","name":"Incorrect Regular Expression"}],"description":"An issue was discovered in regex.yaml (aka regexes.yaml) in UA-Parser UAP-Core before 0.6.0. A Regular Expression Denial of Service (ReDoS) issue allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to a value containing a long digit string. (The UAP-Core project contains the vulnerability, propagating to all implementations.)","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"uap-core Regular Expression Denial of Service issue","id":"CVE-2018-20164","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":4,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-20165"},"packages":[{"ecosystem":"npm","fixed":["0.6.0"],"introduced":["0"],"last_affected":[],"package":"uap-core","purl":null,"source":"GHSA-fx7m-j728-mjw3"},{"ecosystem":"npm","fixed":["0.6.0"],"introduced":["0"],"last_affected":[],"package":"uap-core","purl":"pkg:npm/uap-core","source":"GHSA-fx7m-j728-mjw3"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2018-20162"},"products":["n/a"],"published":"2019-02-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Remote attackers can cause server overload via ReDoS by sending crafted User-Agent headers to applications using the vulnerable UAP-Core library.","url":"https://insights.sbomify.com/CVE-2018-20164/"}